Click here to Skip to main content
15,748,615 members
Please Sign up or sign in to vote.
1.00/5 (1 vote)
See more:
i am trying to upgrade the TLS1.2 in my windows application but when i upgraded it the crystal reports are not getting upgrade into TLS 1.2 and i am not able to open the report in my application.we have the verion in database as sql server as 6.03 and sql server native client 11 as 2011.110.Please help me how to upgrade the report from the application.

What I have tried:

Not getting any option in visual studio to upgrade the report.

since the application is oledb connection i tried to install oledb driver for the TLS 1.2.
Updated 29-Sep-20 10:57am
Sandeep Mewara 29-Sep-20 12:52pm    
Not sure what you mean by "crystal reports are not getting upgrade into TLS 1.2"

TLS is at network level.

1 solution

Okay, re-read the query and believe there is a gap with TLS1.2 support with your SQL server (your crystal report data source) and that could be the reason of the functionality break.

Look here at all the versions and details of SQL server that supports TLS1.2:
TLS 1.2 support for Microsoft SQL Server[^]

Either you have unsupported version of SQL server or you have not yet updated to latest that supports it.
Share this answer
Member 12663263 30-Sep-20 2:46am    
this is related with the above questions and the .Net framework for the application was 3.5 earlier and it is upgraded to 4.6.1.

This content, along with any associated source code and files, is licensed under The Code Project Open License (CPOL)

CodeProject, 20 Bay Street, 11th Floor Toronto, Ontario, Canada M5J 2N8 +1 (416) 849-8900