Click here to Skip to main content
15,609,235 members
Please Sign up or sign in to vote.
0.00/5 (No votes)
See more:
System info: RHEL 5, JBoss (circa 2008)

Our system uses a web app to monitor a process on the system. It connects to https://localhost:8443/App yadda yadda

It suddenly stopped working one day: "The page you are trying to view cannot be shown because the authenticity of the received data could not be verified." (Also the same error if attempted remotely)

The certificates are up-to-date.

openssl s_client -showcerts -connect localhost:8443 gives
error: 140790E5:SSL routines:SSL23_SWRITE:ssl handshake failure:s23_lib.c:188

What I have tried:

Checked the cert(s) : All expire in 2023

Followed instructions after a search to try -ssl3 and -tls1_2 in the openssl command : switches don't work, possible because of very old version.

Looked at system time (ntpd) and see in "/var/log/messages" a 'time reset +133.269228 s', which varying amounts of time all through the log. Drifting like crazy. But would that really upset a connect to localhost? Even if the time is wrong, it's wrong on both ends of the connection. (But sheesh, over two minutes, and it never syncs up)

Of course, stopped and started jboss, rebooted the VM, compared code with working systems, etc. Note: no one did anything to the server, other than looking at the monitor. It 'broke on it own'. As far as I can tell.

Any ideas where else to look for the cause?
Updated 1-Oct-20 4:16am

1 solution

I'd probably upgrade "JBoss 2008" to something more recent. "Suddenly" usually means you upgraded to a new component somewhere that is now incompatible with some older components.

In my case it was Windows 8 PC's stopped talking with Windows 10 due to different levels of security patching. It happened "suddenly" (after a Windows update).
Share this answer
GenJerDan 2-Oct-20 3:12am    
Upgrades are not allowed until vetted by The Powers That Be. No updates to anything have occurred in months. (Closed system, all updates are manually done.)

This content, along with any associated source code and files, is licensed under The Code Project Open License (CPOL)

CodeProject, 20 Bay Street, 11th Floor Toronto, Ontario, Canada M5J 2N8 +1 (416) 849-8900