Click here to Skip to main content
15,743,429 members
Please Sign up or sign in to vote.
1.00/5 (1 vote)
Dear sir,

i am trying to connect to tatendance machine using a windows service iam running on windows enterprize LTSC 64 bit and when registering the service and try to run i got this error , am i missing any dlls or .net framework

iam using zk the files taht come with the attendance program , i tried the service on my personal computer and it is working fine but on the client computer(windows 10 Enterprize LTSC it is not working)

What I have tried:

i registered the dlls successfully on the PC
Updated 22-Oct-20 7:41am
F-ES Sitecore 22-Oct-20 11:21am    
Check the event log or any error logs.
ZurdoDev 22-Oct-20 11:22am    
What he said ^.
Richard MacCutchan 22-Oct-20 12:21pm    
You need to gather more information about what happens when your service starts. People here cannot guess what is going on.
Member 13639193 22-Oct-20 12:21pm    
this error occurs when trying to start the service
Richard MacCutchan 22-Oct-20 13:44pm    
We know that but we have no idea what error you are referring to. Please go and gather some proper information.

1 solution

You would need to troubleshoot and figure out the possible reason by yourself for this one.

Here, have a look at the details of the possible reasons and how to handle them: How to Fix Error 1053: The Service did not Respond to the Start or Control Request in a Timely Fashion? -[^]

Snippet for possible reasons:
- Timeout settings: Windows, by default, has a timeout setting which if not met by applications, forces them to abort and close. If the service which you are trying to launch takes much longer to respond, then it will be killed. Here, we can change the timeout setting by manipulating the registry.
- Missing DLL file: Another instance of the error occurs when you have a missing DLL file on your computer which is used by numerous other applications as well. If this DLL file is in conflict or isn’t present at all, you will experience the error message.
- Corrupt/missing system files: Another instance of why this issue occurs is because there are corrupt or missing system files on your computer. If the very installation of Windows is not proper and has issues, you will experience numerous problems including the error message under discussion.
-Outdated Windows: Microsoft officially recognized this error message on their official website and even released a temporary hotfix to solve the problem. However, recently they removed the hotfix and instructed users to upgrade to the latest iteration of Windows.
- Using a Release build (for Developers): If you are trying to launch services in a Debug build of Windows, you are likely to experience this error message. Debug builds are not stable and don’t have all the functionality running as compared to release builds.
Missing Frameworks (for Developers): Incompatibility of Frameworks are also responsible for causing the error message. The box on which you are trying to run the service and your service itself must be on the same framework.
-An issue in DB service (for Developers): Another instance where you might experience this error message is where there is a problem with your configuration of the project. The server details should correct so the service doesn’t have problem accessing.
- Corrupt installation: Another common instance where you might experience this error message is where the installation of your application (which is prompting the service) is somewhat corrupt. Reinstalling helps here.
Bad network configurations: Services communicate with your network all the time. If your network configurations are not good, the services might not be able to perform their tasks and hence cause the error message under discussion.
- Administrator access: The service which you are trying to launch (or a third-party is trying to launch) should be launched as an administrator if it is consuming system resources not meant for normal use.
Share this answer

This content, along with any associated source code and files, is licensed under The Code Project Open License (CPOL)

  Print Answers RSS
Top Experts
Last 24hrsThis month

CodeProject, 20 Bay Street, 11th Floor Toronto, Ontario, Canada M5J 2N8 +1 (416) 849-8900