Click here to Skip to main content
14,732,890 members
Please Sign up or sign in to vote.
1.00/5 (1 vote)
See more:
I just installed the C# and tried to debug it by playing simple task to make Console.WriteLine("Hello World!") and I'am always geting the same error - [^]

What I have tried:

I tried to reset all C# settings and it didn't helped at all. Also I have tried to reinstall the VisualStudio but it also work for me.
Posted
Updated 27-Oct-20 13:51pm
Comments
BillWoodruff 28-Oct-20 4:52am
   
your screen shot does not show the error message.
Richard MacCutchan 28-Oct-20 6:08am
   
It might have something to do with the fact that you are trying to run VB.NET code, not C#.

Put a breakpoint on the first line in the Main method, and run your app in the debugger to see exactly what is going on.

We can't do that for you - we have no access to your system!
   
Few people have faced this issue and couple of suggestions has been made as solutions[^], try off and see:

#1
Quote:
If you are using a 64-bit windows then set the solution platform to x64 next to the debuggig button, its automatically set to x86 which is for 32-bit systems, i had the same problem and this solved the issue for me.


#2
Quote:
Please check for the existence of one of the following registry keys.

HKEY_LOCAL_MACHINE\Software\Microsoft\Command Processor\AutoRun
HKEY_CURRENT_USER\Software\Microsoft\Command Processor\AutoRun

If they exist and are not expected, please remove. They may be created by malware, so you may need to use an antivirus product to remove the unwanted software.
   
Comments
BillWoodruff 28-Oct-20 4:49am
   
"If they exist and are not expected, please remove." How do you think a naïve user would know if these keys are not expected ?

This content, along with any associated source code and files, is licensed under The Code Project Open License (CPOL)




CodeProject, 20 Bay Street, 11th Floor Toronto, Ontario, Canada M5J 2N8 +1 (416) 849-8900