Click here to Skip to main content
15,072,735 members
Please Sign up or sign in to vote.
0.00/5 (No votes)
See more:
I just upgraded my Windows 7 pro to Windows 10 pro and I find when I double click a .sln or .vbproj file, nothing happens!
However, if I first open VS2008 then select to open the solution file, it loads correctly.
What has happened in Windows 10 and how do I restore normal operation, so I just double click the solution file?

What I have tried:

Renaming the .sln file and saving the project once open in vs2008.
Posted
Comments
Sandeep Mewara 20-Nov-20 0:06am
   
Sounds like you lost the file association.

Check in VS settings to associate it back or else repair/reinstall VS.
Maciej Los 20-Nov-20 4:42am
   
Sounds like an answer, Sandeep.
Sandeep Mewara 21-Nov-20 4:01am
   
:) :thumbsup:
YorkshireCap 20-Nov-20 15:20pm
   
Thanks Sandeep- I have just tried that, but alas, the file still will not double-click open. So I'll see if the VS2008 entry in the apps list allows a repair before I try reinstalling.
Sandeep Mewara 21-Nov-20 4:01am
   
:thumbsup:

Adjust File Associations:
How to Reset Windows 10 File Associations or Change File Type[^]

Your VS is rather old, why don't you use the free Visual Studio Community 2019 ?
   
Comments
YorkshireCap 20-Nov-20 15:31pm
   
Thanks Jo_vb.net, I have tried this but it is already set to the Microsoft Visual Studio Version Selector, as it normally is. I wonder about the free community 2019. I tried a few free versions last year but they refused to work- kept asking for a licence key. I am wary about changing my VS setup which has worked fine for a few years now. I don't like to mess with things that work- it usually goes wrong.
This does at least function if I open VS first then select the file. Also, in my old Windows 7 system it was working just fine, so I could always revert back to that if anything else is a problem. Windows 7 was working just fine; I really don't know why MS changed.
This is why I didn't try upgrading to Windows 10 until now- there are always programs that don't work; drivers that are unavailable, hardware not supported anymore etc.
I've been through it before, when finally moving up to Win XP from W2000, then to Win 7 once the previous version were beginning to be not supported anymore.
I might give the free 2019 a try on a friends laptop to see if it works. I just wonder what the limitations are compared to my full VS2008.
YorkshireCap 22-Nov-20 16:15pm
   
This was the best solution. Running a repair of VS2008 from Control Panel>Programs & Features in Windows 10 failed. So I installed VS2019 community and that fixed it. The install probably sets up the complex permissions between classes, users and brokers etc.
Now my VS2008 files activate the IDE correctly again.
(& I may as well get familiar with VS2019 as well)
I think:
When it's asking for a licence key you only need to login to your Microsoft account, then you should get a free license.
   
Comments
YorkshireCap 20-Nov-20 18:57pm
   
Ah- that's interesting. I usually never use my Microsoft account( I don't like being logged into anybody's servers, because they track you everywhere).
YorkshireCap 21-Nov-20 18:42pm
   
AH- I just checked my system event log and it shows this event every time I try to double-click the sln file:

Log Name: System
Source: Microsoft-Windows-DistributedCOM
Date: 20/11/2020 5:21:09 PM
Event ID: 10016
Task Category: None
Level: Warning
Keywords: Classic
User: PCName\me
Computer: PCName
Description:
The application-specific permission settings do not grant Local Activation permission for the COM Server application with CLSID
{2593F8B9-4EAF-457C-B68A-50F6B8EA6B54}
and APPID
{15C20B67-12E7-4BB6-92BB-7AFF07997402}
to the user PCName\ME SID (S-1-5-21-1570163575-2327016866-318336090-1001) from address LocalHost (Using LRPC) running in the application container Unavailable SID (Unavailable). This security permission can be modified using the Component Services administrative tool.
Event Xml:
<event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
<system>
<provider name="Microsoft-Windows-DistributedCOM" guid="{1B562E86-B7AA-4131-BADC-B6F3A001407E}" eventsourcename="DCOM">
<eventid qualifiers="0">10016
<version>0
<level>3
<task>0
<opcode>0
<keywords>0x8080000000000000
<timecreated systemtime="2020-11-20T23:21:09.9347628Z">
<eventrecordid>1410
<correlation activityid="{b1273329-5655-48b9-862e-74c6a993d7e9}">
<execution processid="600" threadid="11960">
<channel>System
<computer>PCName
<security userid="S-1-5-21-1570163575-2327016866-318336090-1001">

<eventdata>
application-specific
Local
Activation
{2593F8B9-4EAF-457C-B68A-50F6B8EA6B54}
{15C20B67-12E7-4BB6-92BB-7AFF07997402}
PCName
ME
S-1-5-21-1570163575-2327016866-318336090-1001
LocalHost (Using LRPC)
Unavailable
Unavailable




SO, it's a permissions problem, caused by Windows 10 presumably. I suppose Win10 has more security than win7 so it causes more problems for developers.
I tried a method on the web for adding Local permissions to the class ID and appid and the service component but that didn't work SO... I'll try VS2019 Community and try the licence in MS account, as you said. Thank you.

This content, along with any associated source code and files, is licensed under The Code Project Open License (CPOL)




CodeProject, 20 Bay Street, 11th Floor Toronto, Ontario, Canada M5J 2N8 +1 (416) 849-8900