Click here to Skip to main content
14,773,203 members
Please Sign up or sign in to vote.
0.00/5 (No votes)
I getting "no such file or directory" error when I'm trying install typescript.

Npm version : 6.14.8

There is a log file.

0 info it worked if it ends with ok
1 verbose cli [
1 verbose cli   'C:\\Program Files\\nodejs\\node.exe',
1 verbose cli   'C:\\Program Files\\nodejs\\node_modules\\npm\\bin\\npm-cli.js',
1 verbose cli   'install',
1 verbose cli   '-g',
1 verbose cli   'typescript'
1 verbose cli ]
2 info using npm@6.14.8
3 info using node@v14.15.1
4 verbose npm-session d54c56860c77d590
5 silly install loadCurrentTree
6 silly install readGlobalPackageData
7 http fetch GET 304 https://registry.npmjs.org/typescript 452ms (from cache)
8 silly pacote tag manifest for typescript@latest fetched in 512ms
9 timing stage:loadCurrentTree Completed in 547ms
10 silly install loadIdealTree
11 silly install cloneCurrentTreeToIdealTree
12 timing stage:loadIdealTree:cloneCurrentTree Completed in 0ms
13 silly install loadShrinkwrap
14 timing stage:loadIdealTree:loadShrinkwrap Completed in 1ms
15 silly install loadAllDepsIntoIdealTree
16 silly resolveWithNewModule typescript@4.1.2 checking installable status
17 timing stage:loadIdealTree:loadAllDepsIntoIdealTree Completed in 5ms
18 timing stage:loadIdealTree Completed in 7ms
19 silly currentTree npm
20 silly idealTree npm
20 silly idealTree `-- typescript@4.1.2
21 silly install generateActionsToTake
22 timing stage:generateActionsToTake Completed in 3ms
23 silly diffTrees action count 1
24 silly diffTrees add typescript@4.1.2
25 silly decomposeActions action count 8
26 silly decomposeActions fetch typescript@4.1.2
27 silly decomposeActions extract typescript@4.1.2
28 silly decomposeActions preinstall typescript@4.1.2
29 silly decomposeActions build typescript@4.1.2
30 silly decomposeActions install typescript@4.1.2
31 silly decomposeActions postinstall typescript@4.1.2
32 silly decomposeActions finalize typescript@4.1.2
33 silly decomposeActions refresh-package-json typescript@4.1.2
34 silly install executeActions
35 silly doSerial global-install 8
36 verbose correctMkdir C:\Users\İsmail Talha\AppData\Roaming\npm-cache\_locks correctMkdir not in flight; initializing
37 verbose makeCacheDir UID & GID are irrelevant on win32
38 verbose lock using C:\Users\İsmail Talha\AppData\Roaming\npm-cache\_locks\staging-de4a51cb76d5235c.lock for C:\Users\İsmail Talha\AppData\Roaming\npm\node_modules\.staging
39 silly doParallel extract 1
40 silly extract typescript@4.1.2
41 silly tarball trying typescript@latest by hash: sha512-thGloWsGH3SOxv1SoY7QojKi0tc+8FnOmiarEGMbd/lar7QOEd3hvlx3Fp5y6FlDUGl9L+pd4n2e+oToGMmhRQ==
42 warn tar ENOENT: no such file or directory, open 'C:\Users\İsmail Talha\AppData\Roaming\npm\node_modules\.staging\typescript-1e033c33\bin\tsc'
43 warn tar ENOENT: no such file or directory, open 'C:\Users\İsmail Talha\AppData\Roaming\npm\node_modules\.staging\typescript-1e033c33\bin\tsserver'
44 warn tar ENOENT: no such file or directory, open 'C:\Users\İsmail Talha\AppData\Roaming\npm\node_modules\.staging\typescript-1e033c33\lib\cancellationToken.js'
45 warn tar ENOENT: no such file or directory, open 'C:\Users\İsmail Talha\AppData\Roaming\npm\node_modules\.staging\typescript-1e033c33\lib\cs\diagnosticMessages.generated.json'
46 timing npm Completed in 1131ms
47 error cb() never called!
48 error This is an error with npm itself. Please report this error at:
49 error <https://npm.community>


What I have tried:

-Reinstalled npm
-Trying install typescript from node.js command prompt
-Delete node-modules
Posted
Updated 7-Dec-20 0:52am

1 solution

48 error This is an error with npm itself. Please report this error at:
49 error <https://npm.community>
   

This content, along with any associated source code and files, is licensed under The Code Project Open License (CPOL)




CodeProject, 20 Bay Street, 11th Floor Toronto, Ontario, Canada M5J 2N8 +1 (416) 849-8900