Click here to Skip to main content
14,836,551 members
Please Sign up or sign in to vote.
0.00/5 (No votes)
Hello all,
I been trying to figure this out on my own for over a week now and tried so many different things but I have not yet got it working.
I have a linux server I am deploying my .Net Core Web API on, also I am deploying my .Net Core MVC UI on it as well.
They both get deployed successfully and when I use swagger on the API I can successfully reach and access the database.
When I use my UI I run a page to connect to the API I get
This error:
An unhandled exception occurred while processing the request. The remote certificate is invalid because of errors in the certificate chain partialchain
HttpRequestException: the SSL connection could not be established,

What I have tried:

I tried setting up my cookie to connect and be authorized to localhost:port# of API
I ran dotnet dev-certs https –clean
And
Dotnet dev-certs https –trust
And tried many other small things but all with the same result.
My end goal is to get this to work then to put the both in docker containers and have them connect to each other.
In docker containers I get an error im assuming its this same problem. I added ASPNETCORE_ENVIRONMENT: develp[ment to Docker in launchsettings.json thinking that would put it to dev mode in docker container but it didn’t so I don’t get stack trace in docker. But I just wanna figure out this ssl connection not be established.
Posted
Updated 7-Feb-21 6:58am

1 solution

Maybe the information here will help, search for SSL:
Kestrel web server implementation in ASP.NET Core | Microsoft Docs[^]
   

This content, along with any associated source code and files, is licensed under The Code Project Open License (CPOL)

  Print Answers RSS
Top Experts
Last 24hrsThis month



CodeProject, 20 Bay Street, 11th Floor Toronto, Ontario, Canada M5J 2N8 +1 (416) 849-8900