Click here to Skip to main content
15,125,547 members
Please Sign up or sign in to vote.
0.00/5 (No votes)
See more:
Error Message attempting to download data from my SQL Server 2017 dev edition.

0 - The certificate chain was issued by an authority that is not trusted.

I've tried so many suggestions and it's probably because I'm not a certificate expert.

So. Two questions.

As a person with limited DBA experience with advanced settings, how do I resolve this


If I reinstall the same version of SQL Server, will certificates automatically be created?

What I have tried:

My suggestions by Users in CodeProject, all unsuccessfull (probably because of my limited understanding of certificates, which ones to recreate, etc.)
Updated 9-Mar-21 5:17am
NotTodayYo 9-Mar-21 11:11am
Where are you trying to download it from?
stfromli 9-Mar-21 11:41am
I'm connected to the database with a powerbi dashboard. I think this was working until i accidentally closed down my laptop with powerbi active and connected to my SQL Server database.

I then tried to connect to the database using excel, word, etc. but no matter what external software i use i get exactly the same message.
NotTodayYo 9-Mar-21 11:49am
Where is your db? Azure? On your own server? I still don't quite follow exactly what you are doing.
stfromli 9-Mar-21 13:52pm
My database is SQL Server 2017 dev edition and my office/powerbi software is on the same laptop as my SQL Server.

When you connect to your SQL server using excel or powerbi or any office 365 product, you can connect to the database seamlessly as long as you have the id and password. Up until recently i could. Now the error that I reported is preventing me from using my excel, word, powerbi, etc. to connect to the database. The error occurs that I reported in my original question

The actual error is
Microsoft SQL: A connection was successfully established with the server, but then an error occurred during the login process. (provider: SSL Provider, error: 0 - The certificate chain was issued by an authority that is not trusted.)
RedDk 9-Mar-21 13:20pm
Try (under Additional Connection Parameters tab of "Connect to Server" dialog) typing:


The word in forums other than CP is that doing this is not a good idea. So see if it works then perhaps rollback your success to see if you can get login to fail again (back to current state). And think about it.
stfromli 9-Mar-21 13:53pm
Thanks, I'll try that.

I tried restoring my laptop to a previous version but that didn't help.

Question, if I was to reinstall my server, would that automatically resolve the issue I'm having? It's not a production server, just a dev.
RedDk 9-Mar-21 15:44pm
Quote: "reinstall my server"
That's drastic ... but then again, what do you mean by "server"? I don't want to suggest anything to the suggestable.

I use SSMSE. That's an abbreviation for SQL Server Management Studio Express and it allows me to do just about anything a user who wants to become familiar with programming/developing in TSQL would want to do. If you're interested in learning TSQL I'd also suggest downloading the Book-On-Line (BOL) for the version of SSMSE you've installed. All available in MS site ... somewhere.
NotTodayYo 9-Mar-21 14:14pm
That setting is just fine when it's all on their laptop.
stfromli 10-Mar-21 12:07pm
What setting, TrustServerCertificate=True ? Where would I find this setting?
stfromli 9-Mar-21 15:56pm
SSMSE is similar to SQL Server 17 dev, but Dev is a full blown one license version, perfect for someone who has a single piece of hardware. It basically is a one license version of the SQL Server enterprise edition (with a few features missing I don't need.

I know TSQL Very well and my career has been working with it regularly.
But this problem isn't a T-SQL problem, it's a DBA issue. Unfortunately i have next to no experience maintaining certificates.

It actually isn't difficult to uninstall and reinstall. I'm referring to removing it off my lap top and the reinstalling it from scratch. I've done it often so I don't expect any issues but it would be a waste of time to do it if it doesn't fix my problem.

This content, along with any associated source code and files, is licensed under The Code Project Open License (CPOL)

CodeProject, 20 Bay Street, 11th Floor Toronto, Ontario, Canada M5J 2N8 +1 (416) 849-8900