Click here to Skip to main content
14,879,366 members
Please Sign up or sign in to vote.
0.00/5 (No votes)
The emulator successfully opens but without launching the app, despite all necessary components are installed. So, I have no idea how to fix this.


It writes:

12:52 Emulator: handleCpuAcceleration: feature check for hvf

12:52 Emulator: added library vulkan-1.dll


What I have tried:

I have installed all the necessary components including HAXM
Updated 4-Apr-21 0:48am
Comments
Richard MacCutchan 4-Apr-21 7:19am
   
Impossible to give an answer without considerably more detail.
   
I can give you every detail you want because I was fighting with that issue for a long time! Just give me an example of what you need to know.
Richard MacCutchan 4-Apr-21 7:59am
   
Sorry, no idea. We cannot tell what your system is doing, what you have installed, or what problems there are. But this is really a question for the Android Studio support team.
   
Maybe it can be connected to the following IDE error:

update failed for AnAction(com.android.tools.idea.run.ui.ApplyChangesAction) with ID=android.deploy.ApplyChanges

java.lang.UnsatisfiedLinkError: org.sqlite.core.NativeDB._open_utf8([BI)V
at org.sqlite.core.NativeDB._open_utf8(Native Method)
at org.sqlite.core.NativeDB._open(NativeDB.java:71)
at org.sqlite.core.DB.open(DB.java:174)
at org.sqlite.core.CoreConnection.open(CoreConnection.java:220)
at org.sqlite.core.CoreConnection.<init>(CoreConnection.java:76)
at org.sqlite.jdbc3.JDBC3Connection.<init>(JDBC3Connection.java:25)
at org.sqlite.jdbc4.JDBC4Connection.<init>(JDBC4Connection.java:24)
at org.sqlite.SQLiteConnection.<init>(SQLiteConnection.java:45)
at org.sqlite.JDBC.createConnection(JDBC.java:114)
at org.sqlite.JDBC.connect(JDBC.java:88)
at java.sql.DriverManager.getConnection(DriverManager.java:664)
at java.sql.DriverManager.getConnection(DriverManager.java:270)
at com.android.tools.deployer.SqlApkFileDatabase.<init>(SqlApkFileDatabase.java:94)
at com.android.tools.deployer.SqlApkFileDatabase.<init>(SqlApkFileDatabase.java:70)
at com.android.tools.idea.run.DeploymentService.<init>(DeploymentService.java:56)
at sun.reflect.GeneratedConstructorAccessor103.newInstance(Unknown Source)
at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(DelegatingConstructorAccessorImpl.java:45)
at java.lang.reflect.Constructor.newInstance(Constructor.java:423)
at org.picocontainer.defaults.InstantiatingComponentAdapter.newInstance(InstantiatingComponentAdapter.java:193)
at com.intellij.util.pico.CachingConstructorInjectionComponentAdapter.doGetComponentInstance(CachingConstructorInjectionComponentAdapter.java:88)
at com.intellij.util.pico.CachingConstructorInjectionComponentAdapter.instantiateGuarded(CachingConstructorInjectionComponentAdapter.java:66)
at com.intellij.util.pico.CachingConstructorInjectionComponentAdapter.getComponentInstance(CachingConstructorInjectionComponentAdapter.java:48)
at com.intellij.openapi.components.impl.ServiceManagerImpl$MyComponentAdapter.createAndInitialize(ServiceManagerImpl.java:243)
at com.intellij.openapi.components.impl.ServiceManagerImpl$MyComponentAdapter.lambda$getComponentInstance$0(ServiceManagerImpl.java:232)
at com.intellij.openapi.progress.impl.CoreProgressManager.registerIndicatorAndRun(CoreProgressManager.java:591)
at com.intellij.openapi.progress.impl.CoreProgressManager.executeProcessUnderProgress(CoreProgressManager.java:537)
at com.intellij.openapi.progress.impl.ProgressManagerImpl.executeProcessUnderProgress(ProgressManagerImpl.java:59)
at com.intellij.openapi.progress.impl.CoreProgressManager.executeNonCancelableSection(CoreProgressManager.java:197)
at com.intellij.openapi.components.impl.ServiceManagerImpl$MyComponentAdapter.getComponentInstance(ServiceManagerImpl.java:231)
at com.intellij.util.pico.DefaultPicoContainer.getLocalInstance(DefaultPicoContainer.java:246)
at com.intellij.util.pico.DefaultPicoContainer.getComponentInstance(DefaultPicoContainer.java:213)
at com.intellij.openapi.components.ServiceManager.doGetService(ServiceManager.java:75)
at com.intellij.openapi.components.ServiceManager.getService(ServiceManager.java:49)
at com.android.tools.idea.run.DeploymentService.getInstance(DeploymentService.java:48)
at com.android.tools.idea.run.ui.BaseAction.getDisableMessage(BaseAction.java:163)
at com.android.tools.idea.run.ui.BaseAction.update(BaseAction.java:133)
at com.android.tools.idea.run.ui.ApplyChangesAction.update(ApplyChangesAction.java:50)
at com.intellij.openapi.actionSystem.ex.ActionUtil.performDumbAwareUpdate(ActionUtil.java:176)
at com.intellij.openapi.actionSystem.impl.ActionUpdater.doUpdate(ActionUpdater.java:379)
at com.intellij.openapi.actionSystem.impl.ActionUpdater.lambda$null$1(ActionUpdater.java:79)
at com.intellij.openapi.actionSystem.impl.ActionUpdater.callAction(Acti
Richard MacCutchan 4-Apr-21 8:52am
   
The first message is clear, there is some part of the SQLite library missing.
   
How do I know what are the missing components and where to put them?
Richard MacCutchan 4-Apr-21 14:27pm
   
Sorry, I don't know. You need to do more investigation to find out exactly why the error occurs. And that is not something that can be done remotely. Check all the install processes that are connected to this, to see if there were any other errors.
David Crow 4-Apr-21 22:05pm
   
Does the app launch in a real device?

Does the app do the same with all AVDs or just the one?

Have you tried deleting the AVD and creating a new one?

Do other apps launch in the AVD or do they fail too?
   
1) I have got just an empty activity field(it can be launched too) as I didn't want to work while all the components wouldn't operate properly.
2) This happens to all virtual and real devices despite I tried to change/reinstall many of them many times
(As I understood the issue is in the listed above emulator error(hvf and vulkan.dll problems) but I still don't know how to fix them)

This content, along with any associated source code and files, is licensed under The Code Project Open License (CPOL)




CodeProject, 20 Bay Street, 11th Floor Toronto, Ontario, Canada M5J 2N8 +1 (416) 849-8900