Click here to Skip to main content
15,615,469 members
Please Sign up or sign in to vote.
0.00/5 (No votes)
See more:
Hi everybody,

I am developing a plugin Autocad and have a problem about NullReferenceException at line code "

using (Transaction tr = db.TransactionManager.StartTransaction())

How to fix this error. Please have a look code below and advice.

What I have tried:

public void Aba(int Width)
Document doc = AcAp.DocumentManager.MdiActiveDocument;
Database db = doc.Database;
Editor ed = doc.Editor;
//PromptEntityResult selRes = ed.GetEntity("\nPick a Curve entity:");
PromptSelectionOptions selOp = new PromptSelectionOptions();
PromptSelectionResult selRes = ed.GetSelection(selOp);
PromptKeywordOptions chRes = new PromptKeywordOptions("\nVuong hay khong?[Y/N]:", "Y N");
chRes.Keywords.Default = "Y";
PromptResult pStrRes = ed.GetKeywords(chRes);
using (Transaction tr = db.TransactionManager.StartTransaction())
if (selRes.Status == PromptStatus.OK)
SelectionSet acSSet = selRes.Value;

// Step through the objects in the selection set
foreach (SelectedObject acSSObj in acSSet)
Entity ent = (Entity)tr.GetObject(acSSObj.ObjectId, OpenMode.ForRead);
double angle = GetAngle(ent as Curve);
int CurLenght = Convert.ToInt32((GetLength(ent as Curve)));
Updated 12-May-21 21:45pm

You need to use the debugger to find out which reference is null. I assume it is db, but you do not make that clear. Once you have found the correct one you need to work backwards to find out why. And the answer will very much depend on the objects you are creating, the order you do that, and the data that they are working on.
Share this answer
This is one of the most common problems we get asked, and it's also the one we are least equipped to answer, but you are most equipped to answer yourself.

Let me just explain what the error means: You have tried to use a variable, property, or a method return value but it contains null - which means that there is no instance of a class in the variable.
It's a bit like a pocket: you have a pocket in your shirt, which you use to hold a pen. If you reach into the pocket and find there isn't a pen there, you can't sign your name on a piece of paper - and you will get very funny looks if you try! The empty pocket is giving you a null value (no pen here!) so you can't do anything that you would normally do once you retrieved your pen. Why is it empty? That's the question - it may be that you forgot to pick up your pen when you left the house this morning, or possibly you left the pen in the pocket of yesterday's shirt when you took it off last night.

We can't tell, because we weren't there, and even more importantly, we can't even see your shirt, much less what is in the pocket!

Back to computers, and you have done the same thing, somehow - and we can't see your code, much less run it and find out what contains null when it shouldn't.
But you can - and Visual Studio will help you here. Run your program in the debugger and when it fails, VS will show you the line it found the problem on. You can then start looking at the various parts of it to see what value is null and start looking back through your code to find out why. So put a breakpoint at the beginning of the method containing the error line, and run your program from the start again. This time, VS will stop before the error, and let you examine what is going on by stepping through the code looking at your values.

But we can't do that - we don't have your code, we don't know how to use it if we did have it, we don't have your data. So try it - and see how much information you can find out!
Share this answer

This content, along with any associated source code and files, is licensed under The Code Project Open License (CPOL)

CodeProject, 20 Bay Street, 11th Floor Toronto, Ontario, Canada M5J 2N8 +1 (416) 849-8900