Click here to Skip to main content
15,885,767 members
Please Sign up or sign in to vote.
1.00/5 (3 votes)
See more:
Covid is highly spreading. Some cities are highly effected. Harry has prepared a Right angle triangle chart of N rows.

H1
H2 H3
H4 H5 H6
H7 H8 H9 H10

Here N is 4

Now his sister need to do following modification: 1. Remove the H from the pattern
After counting the total number of cities present in the pattern she finds the last digit of that number.
Then she replaces the City number with X whose number is ending with same last digit get in step 2.
Input Format
First Line contain a single Integer N denoting the row size given by Harry
Constraints
1<=N<=10^9
Output Format
Contain Pattern each element is separated by one space only
Sample Input 0
5

Sample Output 0

1
2 3
4 X 6
7 8 9 10
11 12 13 14 X


What I have tried:

C++
#include <stdio.h>
#include <string.h>
#include <math.h>
#include <stdlib.h>

int main() {
   int rows, i, j, number = 1;
   printf("Enter the number of rows: ");
   scanf("%d", &rows);
   for (i = 1; i <= rows; i++) 
   {
      for (j = 1; j <= i; ++j) 
      {
         printf("%d ", number);
         ++number;
      }
      printf("\n");
   }
   return 0;
}
Posted
Updated 12-Jun-21 6:39am
v3
Comments
Patrice T 12-Jun-21 3:44am    
And you have a question ?

You are learning and homework is training, nobody can do it for you.
Do you think Usain Bolt asked someone to train for him when he was a beginner ?

You show no attempt to solve the problem yourself, you have no question, your main effort is pasting the requirement, you just want us to do your HomeWork.
HomeWork problems are simplified versions of the kind of problems you will have to solve in real life, their purpose is learning and practicing.

We do not do your HomeWork.
HomeWork is not set to test your skills at begging other people to do your work, it is set to make you think and to help your teacher to check your understanding of the courses you have taken and also the problems you have at applying them.
Any failure of you will help your teacher spot your weaknesses and set remedial actions.
Any failure of you will help you to learn what works and what don't, it is called 'trial and error' learning.
So, give it a try, reread your lessons and start working. If you are stuck on a specific problem, show your code and explain this exact problem, we might help.
 
Share this answer
 
While we are more than willing to help those that are stuck, that doesn't mean that we are here to do it all for you! We can't do all the work, you are either getting paid for this, or it's part of your grades and it wouldn't be at all fair for us to do it all for you.

So we need you to do the work, and we will help you when you get stuck. That doesn't mean we will give you a step by step solution you can hand in!
Start by explaining where you are at the moment, and what the next step in the process is. Then tell us what you have tried to get that next step working, and what happened when you did.

If you are having problems getting started at all, then this may help: How to Write Code to Solve a Problem, A Beginner's Guide[^]
 
Share this answer
 
Divide both numbers by 10 and compare the remainders. e.g:
C++
int modr = rows % 10;
int modn = number % 10;
if (modr == modn)
    printf("X ");
else
    printf("%d ", number);
 
Share this answer
 
v2

This content, along with any associated source code and files, is licensed under The Code Project Open License (CPOL)



CodeProject, 20 Bay Street, 11th Floor Toronto, Ontario, Canada M5J 2N8 +1 (416) 849-8900