Click here to Skip to main content
15,122,845 members
Please Sign up or sign in to vote.
0.00/5 (No votes)
I want to deploy an application to a server using Web Deploy. The main component uses .NET5 while the other two use the 4.8 framework. I can only see one migration in the configurator. How to add remaining migrations to the WebDeploy configurator?

What I have tried:

I tried add to pubxmluser. But I dont see migrations
<ItemGroup>
    <DestinationConnectionStrings Include="DefaultConnection">
      <Value>Server=****%3bDatabase=****%3bIntegrated Security=true%3bMultipleActiveResultSets=true</Value>
    </DestinationConnectionStrings>
    <DestinationConnectionStrings Include="QualityControlConnection">
      <Value>Server=*****%3bDatabase=****%3bIntegrated Security=true%3bMultipleActiveResultSets=true</Value>
    </DestinationConnectionStrings>
    <DestinationConnectionStrings Include="TLCConnection">
      <Value>Server=*****%3bDatabase=****s%3bIntegrated Security=true%3bMultipleActiveResultSets=true</Value>
    </DestinationConnectionStrings>
  </ItemGroup>
Posted
Comments
Szkaradek-Przemyslaw 23-Jun-21 7:22am
   
The problem is with Entity Framework 4.8 because it does not see EF 4.8 based contexts in the web deploy configurator.
There is no such problem with .NET 5.0.

This content, along with any associated source code and files, is licensed under The Code Project Open License (CPOL)




CodeProject, 20 Bay Street, 11th Floor Toronto, Ontario, Canada M5J 2N8 +1 (416) 849-8900