Click here to Skip to main content
15,936,758 members
Please Sign up or sign in to vote.
1.00/5 (1 vote)
I am trying to create an social application which allow users to post something fetching their location and show that post only to the nearest users. However, i am getting NPE error while fetching the longitude and latitude of user. I couldnot figureout what actually is wrong with my code. Here is the error:
Caused by: java.lang.NullPointerException: Attempt to invoke virtual method 'double android.location.Location.getLatitude()' on a null object reference
       at com.jstechnologies.helpinghands.utils.AddressUtils.getAddressFromGps(AddressUtils.java:44)
       at com.jstechnologies.helpinghands.ui.MyApp.getAddress(MyApp.java:30)
       at com.jstechnologies.helpinghands.ui.views.dashBoard.DashBoardViewModel.fetchAddress(DashBoardViewModel.java:65)
       at com.jstechnologies.helpinghands.ui.views.dashBoard.DashBoardActivity.onCreate(DashBoardActivity.java:64)
       at android.app.Activity.performCreate(Activity.java:7136)
       at android.app.Activity.performCreate(Activity.java:7127)
       at android.app.Instrumentation.callActivityOnCreate(Instrumentation.java:1272)

This is my AddressUtils.java file

import androidx.core.app.ActivityCompat;
import androidx.fragment.app.Fragment;
import pub.devrel.easypermissions.AfterPermissionGranted;
import pub.devrel.easypermissions.EasyPermissions;

public class AddressUtils {
    private static final int RC_LOCATION_PERMISSION = 102;

    @AfterPermissionGranted(RC_LOCATION_PERMISSION)
    public Address getAddressFromGps(Context context) throws IOException {

        String[] perms = {Manifest.permission.ACCESS_COARSE_LOCATION, Manifest.permission.ACCESS_FINE_LOCATION};
        if (EasyPermissions.hasPermissions(context, perms)) {
            String provider;
            LocationManager locationManager = (LocationManager) context.getSystemService(Context.LOCATION_SERVICE);
            Criteria criteria = new Criteria();
            provider = locationManager.getBestProvider(criteria, false);


            @SuppressLint("MissingPermission")
            Location location = locationManager.getLastKnownLocation(provider);
            Geocoder geocoder= new Geocoder(context, Locale.getDefault());
            List<android.location.Address> addresses  = geocoder.getFromLocation(location.getLatitude(),location.getLongitude(), 1);
            Address address= new Address();

//ACCORDING TO LOGCAT THIS BELOW LINE HAS ERROR I GUESS

            address.setLat(location.getLatitude());
            address.setLon(location.getLongitude());
            address.setCountry(addresses.get(0).getCountryName());
            address.setCity(addresses.get(0).getLocality());
            address.setState(addresses.get(0).getAdminArea());
            address.setPincode(addresses.get(0).getPostalCode());
            address.setAddressLine1(addresses.get(0).getAddressLine(0));
            address.setAddressLine2(addresses.get(0).getAddressLine(1));

            return address;
        } else {
            EasyPermissions.requestPermissions((Activity) context,"Location permissions are required",RC_LOCATION_PERMISSION,perms);
            return null;
        }

    }
}


What I have tried:

I have tried to null check inside observer, however, this doesnot fix the problem at all.
Posted
Updated 5-Jul-21 18:35pm
Comments
Richard MacCutchan 6-Jul-21 3:27am    
It happens because the variable Address or location is null. Use the debugger to find out why.
David Crow 6-Jul-21 9:02am    
getLastKnownLocation() gets the last known location, or null if there is no last known location. You need to account for the latter.

1 solution

This is one of the most common problems we get asked, and it's also the one we are least equipped to answer, but you are most equipped to answer yourself.

Let me just explain what the error means: You have tried to use a variable, property, or a method return value but it contains null - which means that there is no instance of a class in the variable.
It's a bit like a pocket: you have a pocket in your shirt, which you use to hold a pen. If you reach into the pocket and find there isn't a pen there, you can't sign your name on a piece of paper - and you will get very funny looks if you try! The empty pocket is giving you a null value (no pen here!) so you can't do anything that you would normally do once you retrieved your pen. Why is it empty? That's the question - it may be that you forgot to pick up your pen when you left the house this morning, or possibly you left the pen in the pocket of yesterday's shirt when you took it off last night.

We can't tell, because we weren't there, and even more importantly, we can't even see your shirt, much less what is in the pocket!

Back to computers, and you have done the same thing, somehow - and we can't see your code, much less run it and find out what contains null when it shouldn't.
But you can - and the debugger will help you here. Run your program in the debugger and when it fails, it will show you the line it found the problem on. You can then start looking at the various parts of it to see what value is null and start looking back through your code to find out why. So put a breakpoint at the beginning of the method containing the error line, and run your program from the start again. This time, the debugger will stop before the error, and let you examine what is going on by stepping through the code looking at your values.

But we can't do that - we don't have your code, we don't know how to use it if we did have it, we don't have your data. So try it - and see how much information you can find out!
 
Share this answer
 

This content, along with any associated source code and files, is licensed under The Code Project Open License (CPOL)



CodeProject, 20 Bay Street, 11th Floor Toronto, Ontario, Canada M5J 2N8 +1 (416) 849-8900