Click here to Skip to main content
15,077,474 members
Please Sign up or sign in to vote.
0.00/5 (No votes)
See more:
Hi All,

I am migrating my Intranet application to Azure.I am struggling with LDAP authentication. Please take a look and help.
--
We have running an Intranet Application from On-Prem server 'A'. LDAP authenticaion successfully done at AD server 'B'. Both are in Domain 'X'

Usually, employees are logging in with the user credentials 'USR0123' & password. Once, their credential check is succeeded, then the site will open the HOME page.
My LDAP query is "LDAP://DomainX.local/DC=DomainX,DC=local". Which is currently working fine in 'DomainX'.

Now, we are migrating the Intranet application to Azure.
An Azure server 'C' created to have the above said 'Intranet application and deployed.
The server 'C' and the server 'B' are trusted between them for LDAP authentication purpose.

The Problem is:
When the 'USR0123' logged into the 'Intranet Application from the server 'A' or 'C', it throws an error as below.
"Login failed for user 'aa.adminuser'".
Actually, the user keyed his user id 'USR0123' only.
But, it shows the failure message for *azure user id (aa.adminuser).
For every user it's showing the same error.

As, I am not familiar with LDAP in deep.
Please help me in
- what i need to do with my existing LDAP query.

Thanks.

What I have tried:

1. I have changed "LDAP://DomainX.local/DC=DomainX,DC=local" to
"LDAP://DCServer.DomainX.local/DC=DomainX,DC=local"
2. Network team checked the ports and TCP connections. TcpTestSucceeded.
Posted
Updated 4-Aug-21 7:34am
v3
Comments
Richard Deeming 5-Aug-21 4:58am
   
You'll probably need to update your code to specify the credentials of a valid user in your AD domain when connecting from Azure. But since we can't see your code, we can't tell you how to do that.

This content, along with any associated source code and files, is licensed under The Code Project Open License (CPOL)

  Print Answers RSS
Top Experts
Last 24hrsThis month



CodeProject, 20 Bay Street, 11th Floor Toronto, Ontario, Canada M5J 2N8 +1 (416) 849-8900