Click here to Skip to main content
15,299,443 members
Please Sign up or sign in to vote.
0.00/5 (No votes)
See more:
Hello,

I'm facing an issue when I'm trying to put an application (which is working locally on tomcat 8.5.60 and anothers server on tomcat 8) on a server.
The application has an instable comportement, sometimes partially working, sometimes http 500 error. (there is actually two servers and load balancing)
The server is running on 8.5.60.
One of the log which awarn me is

10:48:46.173 DEBUG o.a.c.d.D.sax.startPrefixMapping() l.1593 | startPrefixMapping(,http://java.sun.com/xml/ns/javaee)
10:48:46.174 DEBUG o.a.c.d.D.sax.startPrefixMapping() l.1593 | startPrefixMapping(xsi,http://www.w3.org/2001/XMLSchema-instance)
10:48:46.174 DEBUG o.a.c.d.D.sax.startElement() l.1520 | startElement(http://java.sun.com/xml/ns/javaee,web-app,web-app)
10:48:46.175 DEBUG o.a.c.d.Digester.startElement() l.1527 |   Pushing body text ''
10:48:46.175 DEBUG o.a.c.d.Digester.startElement() l.1546 |   New match='web-app'
10:48:46.176 DEBUG o.a.c.d.Digester.startElement() l.1574 |   No rules found matching 'web-app'.


How is it possible that the application could not read its web.xml ?

thanks by advance for your answers

What I have tried:

I tried to find other logs, I tried to make it work on others servers, I tried to make it work locally
Posted

This content, along with any associated source code and files, is licensed under The Code Project Open License (CPOL)



CodeProject, 20 Bay Street, 11th Floor Toronto, Ontario, Canada M5J 2N8 +1 (416) 849-8900