Click here to Skip to main content
15,791,739 members
Please Sign up or sign in to vote.
0.00/5 (No votes)
See more:
I am trying to use Tensorflow object detection API,but the CUDNN version that I getting on colab is 8.0. and I want to use 8.1,so how do I upgrade CUDNN library on colab ?
Below is the script I wrote ,but it does'nt seem to have any effect,what is wrong ? is there any other way ?

!sudo apt install cuda-toolkit-11-2
!sudo mv /etc/apt/preferences.d/cuda-repository-pin-600
!sudo apt-key adv --fetch-keys
!sudo add-apt-repository "deb /"
!sudo apt-get update
!sudo apt-get -y install cuda
!sudo apt --fix-broken install
!sudo apt install cuda-cudart-11-2
import os
os.environ['PATH'] = '/usr/local/cuda-11.2/bin:/usr/local/nvidia/bin:/usr/local/cuda/bin:/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/tools/node/bin:/tools/google-cloud-sdk/bin:/opt/bin'
os.environ['LD_LIBRARY_PATH'] = '/usr/local/cuda-11.2/lib64:/usr/local/cuda-11.2/lib64:/usr/lib64-nvidia'
!cp "/content/drive/My Drive/cudnn-11.2-linux-x64-v8.1.0.0.tgz" "/content/cudnn-11.2.tgz"
!mkdir cudnn
!tar -C cudnn/ -zxvf cudnn-11.2.tgz
%cd cudnn/
!sudo cp cuda/include/cudnn*.h /usr/local/cuda-11.2/include
!sudo cp cuda/lib64/libcudnn* /usr/local/cuda-11.2/lib64
!sudo chmod a+r /usr/local/cuda-11.2/include/cudnn*.h /usr/local/cuda-11.2/lib64/libcudnn*
!sudo ldconfig
%cd /content/

Check Cuda and Cudnn version

! nvcc --version

import chainer
print("-----------------SYSTEM INFO----------------------")

I am following this official blog to check for compatible versions of CUDA,CUDNN and Tensorflow : TensorFlow

What I have tried:

I tried changing the variable but did'nt work.

This content, along with any associated source code and files, is licensed under The Code Project Open License (CPOL)

CodeProject, 20 Bay Street, 11th Floor Toronto, Ontario, Canada M5J 2N8 +1 (416) 849-8900