Click here to Skip to main content
15,566,496 members
Please Sign up or sign in to vote.
1.00/5 (1 vote)
See more:
Data was saved without image, while trying get image from MySQL to jLabel by tableMouseClicking, I have this error "
Cannot read the array length because "buf" is null
How Can I avoid this error?

What I have tried:

private void rasmActionPerformed(java.awt.event.ActionEvent evt) {                                     
        JFileChooser chooser = new JFileChooser();
        FileNameExtensionFilter imageFNEF = new FileNameExtensionFilter("IMAGES", "png", "jpeg", "jpg");
        File f = chooser.getSelectedFile();

        String filename = f.getAbsolutePath();
        ImageIcon imageIcon = new ImageIcon(new ImageIcon(filename).getImage().getScaledInstance(imgoq.getWidth(), imgoq.getHeight(), Image.SCALE_DEFAULT));
        try {

            File image = new File(filename);
            FileInputStream fis = new FileInputStream(image);
            ByteArrayOutputStream bos = new ByteArrayOutputStream();
            byte[] buf = new byte[1024];

            for (int readNum; (readNum = != -1;) {

                bos.write(buf, 0, readNum);
            person_image = bos.toByteArray();
        } catch (IOException e) {
            JOptionPane.showMessageDialog(null, e);


private Image ScaledImage(byte[] img, int w, int h) {
        BufferedImage resizedImage = new BufferedImage(w, h, BufferedImage.TYPE_INT_RGB);
        try {
            Graphics2D g2 = resizedImage.createGraphics();
            g2.setRenderingHint(RenderingHints.KEY_INTERPOLATION, RenderingHints.VALUE_INTERPOLATION_BILINEAR);

            // convert byte array back to BufferedImage
            ByteArrayInputStream in = new ByteArrayInputStream(img);
            BufferedImage bImageFromConvert =;

            g2.drawImage(bImageFromConvert, 0, 0, w, h, null);
        } catch (IOException ex) {
        return resizedImage;

private void getValue() {
        try {
            String add1 = rs.getString("oqid");
            String add2 = rs.getString("oqismi");
            String add3 = rs.getString("oqfam");
            String add4 = rs.getString("oqtr");
            String add5 = rs.getString("oqman");
            String add9 = rs.getString("oqfan");

            byte[] imageData = rs.getBytes("oqrasm");
            format = new ImageIcon(ScaledImage(imageData, imgoq.getWidth(), imgoq.getHeight()));
        } catch (SQLException e) {
            JOptionPane.showMessageDialog(null, e);

private void teacher_tableMouseClicked(java.awt.event.MouseEvent evt) {                                           
        // Table mouse
        try {
            int row = teacher_table.getSelectedRow();
            String tableClick = (teacher_table.getModel().getValueAt(row, 0).toString());
            String sql = "select * from oqituvchi where oqid= '" + tableClick + "' ";
            pst = conn.prepareStatement(sql);
            rs = pst.executeQuery();
            if ( {

        } catch (SQLException e) {
            JOptionPane.showMessageDialog(null, e);
Updated 12-Feb-22 0:23am
Richard MacCutchan 12-Feb-22 6:30am    
Which line does the error occur on?
Akramjon 19-Feb-22 6:06am    
ByteArrayInputStream in = new ByteArrayInputStream(img);
Richard MacCutchan 20-Feb-22 3:34am    
That does not make sense as the error message clearly refers to the variable buf.

1 solution

This is one of the most common problems we get asked, and it's also the one we are least equipped to answer, but you are most equipped to answer yourself.

Let me just explain what the error means: You have tried to use a variable, property, or a method return value but it contains null - which means that there is no instance of a class in the variable.
It's a bit like a pocket: you have a pocket in your shirt, which you use to hold a pen. If you reach into the pocket and find there isn't a pen there, you can't sign your name on a piece of paper - and you will get very funny looks if you try! The empty pocket is giving you a null value (no pen here!) so you can't do anything that you would normally do once you retrieved your pen. Why is it empty? That's the question - it may be that you forgot to pick up your pen when you left the house this morning, or possibly you left the pen in the pocket of yesterday's shirt when you took it off last night.

We can't tell, because we weren't there, and even more importantly, we can't even see your shirt, much less what is in the pocket!

Back to computers, and you have done the same thing, somehow - and we can't see your code, much less run it and find out what contains null when it shouldn't.
But you can - and Visual Studio will help you here. Run your program in the debugger and when it fails, it will show you the line it found the problem on. You can then start looking at the various parts of it to see what value is null and start looking back through your code to find out why. So put a breakpoint at the beginning of the method containing the error line, and run your program from the start again. This time, the debugger will stop before the error, and let you examine what is going on by stepping through the code looking at your values.

But we can't do that - we don't have your code, we don't know how to use it if we did have it, we don't have your data. So try it - and see how much information you can find out!
Share this answer

This content, along with any associated source code and files, is licensed under The Code Project Open License (CPOL)

CodeProject, 20 Bay Street, 11th Floor Toronto, Ontario, Canada M5J 2N8 +1 (416) 849-8900