Click here to Skip to main content
15,615,583 members
Please Sign up or sign in to vote.
0.00/5 (No votes)
See more:
Hi guys, good afternoon :)
I do a deploy on my AIX machine geddistri04 which the AIX version is 7.1. When I restart the oplink process, my parent process 63308256 is not exist.

[desenv20@geddistri04]/ambiente/producao/desenv20/exec/funcn/bin> DO*


[desenv20@geddistri04]/ambiente/producao/desenv20/exec/funcn/bin> UP*

Saving the log archive..
              ./nohup.out => ./Log/nohup.out.20220410144659
       * compressing data...
 -- file unchanged
       * remove old files...
       * saving operations logs...
              ./Log/oplinkse.log => ./Log/oplinkse.log.20220410144659
       * compressing data... complete.
Up Openlink session..
Sending output to nohup.out

[desenv20@geddistri04]/ambiente/producao/desenv20/exec/funcn/bin> ps -ef | grep 63308256
desenv20  1638962  6554358   0 15:47:09  pts/4  0:00 grep 63308256

I google it and he discoverd that's a defunct process. How can I ative it for the correct process? May I do it linking to a program or process? I google it but I didn't found anything to help me.

What I have tried:

I tried to run the process to plug in the oplink server, but the process ends quickly without chance to restart. I tried to kill all defunct process and recompile the environment but still with the same problem. I can't restart the machine because I'm not admin.
Updated 10-Apr-22 7:30am

1 solution

A defunct process is a process that has exited, but the parent process has not called wait() for it yet. The wait() system call returns the child process exit value to the parent for whatever processing it might need to do based on whether the process succeeded or not. Since the process has exited, you cannot kill it - as you've found out. This is true for root as well. A defunct process stays in the process table until a wait() call has been made (I think maybe if the parent exits then that works too .. not 100% sure about that).
I think you'll have to discuss the problem with supplier of the OpenLink software. If a reboot is needed, you'll have to discuss with the system admin.

NB. You can find out the status of a process (or some processes) by using the -p flag for ps e.g.
$ ps -fp 1234,9876,34567
will do ps -f for processes 1234, 9876, 34567. If you only need to examine one process, then just use ps -fp pid
Share this answer

This content, along with any associated source code and files, is licensed under The Code Project Open License (CPOL)

CodeProject, 20 Bay Street, 11th Floor Toronto, Ontario, Canada M5J 2N8 +1 (416) 849-8900