Click here to Skip to main content
15,350,424 members
Please Sign up or sign in to vote.
0.00/5 (No votes)
I am using the Crystal Reports native ReportViewer to show reports in my application - everything else seems to be working fine, but the native PrintButton seems to just... not fire, without any error message or exception thrown - and it seems all available information about this issue online is regarding the Web/ASP.Net version of Crystal Reports and not the WinForms/VB.Net one.

What I have tried:

I cannot seem to find a solution about the issue online, so I don't know where to start with regard to debugging the issue, let alone fixing it. I have tried deleting and re-adding the Report Viewer, but it did not seem to fix anything.
Posted
Updated 5-May-22 19:47pm
v2

1 solution

Just to close this, the issue was due to a corrupted installation of the Crystal Reports Redistributable package on the client machine. Installing a newer version has fixed the issue.
   
Comments
Sandeep Mewara 6-May-22 2:05am
   
Thanks for sharing and closing on it. :thumbsup:

This content, along with any associated source code and files, is licensed under The Code Project Open License (CPOL)

  Print Answers RSS
Top Experts
Last 24hrsThis month


CodeProject, 20 Bay Street, 11th Floor Toronto, Ontario, Canada M5J 2N8 +1 (416) 849-8900