Click here to Skip to main content
15,436,928 members
Please Sign up or sign in to vote.
1.00/5 (3 votes)
See more:
My application is MVC.we deploy the code through azure pipelines. IIS server. In local my code changes are working fine. Verified by debugging but the same is not working after we deploy. Verified in server. The pushed changes are available.

What I have tried:

Tried putting logs inside the page but that change also not worked.
Posted
Updated 6-Jul-22 23:28pm
Comments
Graeme_Grant 4-Jul-22 22:23pm    
Not enough information - "is not working after we deploy" - this tells us nothing. How and what happens? What errors? etc... specifics are everything.
GoJo Vana 4-Jul-22 22:36pm     CRLF
I'm not getting any error. Simply code to filter some roles of the user which will pass to one SP. But this filter functionality is not working. Kinda server issue. If i modify the existing SP in the .net code with new SP name which is not available in my DB. It still works fine. Whatever changes we make in .net code when i access UI after deployment new changes not taking
j snooze 5-Jul-22 17:33pm    
Is this javascript code changes? Is the page still using cached javascript code? Did you version the javascript? If this is C# code behind changes, can you verify the dll dates match between server and local machine?

1 solution

When you deploy new javascript code, sometimes you have to clear the browser's cache data in order for it to re-load the .js file. Sometimes, doing a Ctrl-F5 will perform the reload without clearing the cache.
 
Share this answer
 

This content, along with any associated source code and files, is licensed under The Code Project Open License (CPOL)

  Print Answers RSS
Top Experts
Last 24hrsThis month


CodeProject, 20 Bay Street, 11th Floor Toronto, Ontario, Canada M5J 2N8 +1 (416) 849-8900