Click here to Skip to main content
15,798,592 members
Please Sign up or sign in to vote.
0.00/5 (No votes)
See more:
Configuration Details : Tomcat version : 9.0.54 Windows : Windows 10 Enterprise 64 bit Edition

How to disable SeImpersonateprivilege ?

What I have tried:

Trial 1 : Removed "Local Service" from "Local Security Policy" of Windows 10 Configuration. Check ProcessExplorer (In attachment) still showing SeImpersonatePrivilege enabled. Trial 2: Created "new user" from "Edit local user and groups" and added as Apache Tomcat log on user. Still SeImpersonatePrivilege is enabled.
Updated 9-Nov-22 23:11pm

1 solution

Basically it's needed for security reasons as security tokens for process and user are different.

There's possible solution probably as I haven't tried it myself:

GitHub - TarlogicSecurity/sepriv: Tool to manage user privileges[^]
Share this answer

This content, along with any associated source code and files, is licensed under The Code Project Open License (CPOL)

CodeProject, 20 Bay Street, 11th Floor Toronto, Ontario, Canada M5J 2N8 +1 (416) 849-8900