Click here to Skip to main content
15,946,988 members
Please Sign up or sign in to vote.
0.00/5 (No votes)
See more:
This is fresh windows install and fresh BlueIris install. As soon as the camera connects it causes the bellow log from Code Project.

Quote:
2:40:53 pm: Server: This is a new, unreleased version
2:44:59 pm: Dequeued 'detect' request, id XXXXXXXX
2:44:59 pm: Queued: 'detect' request, id XXXXXXXX
2:44:59 pm: Fatal error. System.AccessViolationException: Attempted to read or write protected memory. This is often an indication that other memory is corrupt.
2:44:59 pm: System.__Canon, System.Private.CoreLib, Version=6.0.0.0, Culture=neutral, PublicKeyToken=7cec85d7bea7798e: .b__1(Int32)
2:44:59 pm: System.__Canon, System.Private.CoreLib, Version=6.0.0.0, Culture=neutral, PublicKeyToken=XXXX: .b__1(System.Threading.Tasks.RangeWorker ByRef, Int32, Boolean ByRef)
2:44:59 pm: at System.Threading.Tasks.TaskReplicator+Replica.Execute()
2:44:59 pm: at System.Threading.Tasks.TaskReplicator+Replica+<>c.<.ctor>b__4_0(System.Object)
2:44:59 pm: at System.Threading.Tasks.Task.InnerInvoke()
2:44:59 pm: at System.Threading.Tasks.Task+<>c.<.cctor>b__272_0(System.Object)
2:44:59 pm: at System.Threading.ExecutionContext.RunFromThreadPoolDispatchLoop(System.Threading.Thread, System.Threading.ExecutionContext, System.Threading.ContextCallback, System.Object)
2:44:59 pm: at System.Threading.Tasks.Task.ExecuteWithThreadLocal(System.Threading.Tasks.Task ByRef, System.Threading.Thread)
2:44:59 pm: at System.Threading.ThreadPoolWorkQueue.Dispatch()
2:44:59 pm: at System.Threading.PortableThreadPool+WorkerThread.WorkerThreadStart()
2:44:59 pm: at System.Threading.Thread.StartCallback()
2:44:59 pm: ObjectDetectionNet.exe: has exited
2:45:01 pm: Latest version available is 1.6.7-Beta


Any help in what direction to look would be much appreciated?

What I have tried:

Attempted a complete rebuild of windows and blueiris, replacing ram with different know good modules. Every setting in BlueIris I can think of, with/without hardware acceleration different cameras makes and models. pc is an intel NUC8i7.
tried on a virtual machine with the same outcome.
Posted
Updated 3-Dec-22 21:14pm

1 solution

There is a dedicated forum for AI issues at CodeProject.AI Discussions[^].
 
Share this answer
 

This content, along with any associated source code and files, is licensed under The Code Project Open License (CPOL)



CodeProject, 20 Bay Street, 11th Floor Toronto, Ontario, Canada M5J 2N8 +1 (416) 849-8900