Click here to Skip to main content
15,797,062 members
Please Sign up or sign in to vote.
0.00/5 (No votes)
See more:
I have a WPF project that uses SQLite. My current version builds and runs fine.

I have just restored the last-deployed version from Git. The code builds but the following post-build commands on the main exe project fail:

xcopy "$(SolutionDir)MyProj.Data\bin\$(ConfigurationName)\x86\SQLite.Interop.dll" "$(SolutionDir)MyProj\bin\$(ConfigurationName)\x86\*.*" /C /F /S /E /Y

xcopy "$(SolutionDir)MyProj.Data\bin\$(ConfigurationName)\x64\SQLite.Interop.dll" "$(SolutionDir)MyProj\bin\$(ConfigurationName)\x64\*.*" /C /F /S /E /Y

The reason these commands fail is because the source folders in the MyProj.Data DLL project do not exist.

On the current project, if I delete these same folders, they magically re-appear, yet these missing folders are not built in the older version of the solution. I can't figure out why. I must be missing something obvious.

Any help would save what hair I have remaining.

What I have tried:

I have tried searching all files (*.*) in the whole solution folder tree for the word 'Interop'. In both projects, I get exactly the same results. A comparison of the search results is binary identical.

I have also checked things like nuget package references and project build settings but can find no differences there either.

If I manually copy the Debug/x86 and Debug/x64 folders from the newer working project to the older broken one, the older project then builds and runs without error.
Updated 15-Dec-22 4:50am

1 solution

Set your project build platform to "Any CPU", then install the nuget package "System.Data.SQlite".
Share this answer

This content, along with any associated source code and files, is licensed under The Code Project Open License (CPOL)

CodeProject, 20 Bay Street, 11th Floor Toronto, Ontario, Canada M5J 2N8 +1 (416) 849-8900