Click here to Skip to main content
15,943,294 members
Please Sign up or sign in to vote.
0.00/5 (No votes)
See more:
The sequence...

* All is well

* X-Amount of time goes by
* (X equals a few days, maybe a few weeks)

* Suddenly, My browser cannot connect to HTTPS (note the "S") websites
* My browser does properly connect to HTTP (no "S") websites

* I try a different browser
* Same behavior

* I Open A Command Line Window
* I can ping Google, ATT, BING, and apparently anybody who will respond
* Response is typically in the 16 to 35 millisecond range

The first time this happened, it was a highly confusing event. The second and third time qualify these as iterations of an entrenched process.

What I have tried:

I have no clue, nor do I have any idea of how to ask this question to a qualified search engine (Google and Bing both led me to turbo obfuscation)

This is hardly a fix, but it's the only thing I know how to do at this moment...

* Open Control Panel
* Search for Recovery
* Restore System Files And Settings; Look over the restore points
* Find a date and time when I sortta'kinda remember things were okay
* Click "Next"
* Click "Finish"
* Go do housework, make it perfect and pristine, and Hope the fix worked
* If not, repeat the process with a different restore point
Richard Deeming 5-Jan-23 10:49am    
What error message do you get when the problem occurs?

Could something be disabling TLS1.2 for client connections?
Restrict cryptographic algorithms and protocols - Windows Server | Microsoft Learn[^]
C-P-User-3 5-Jan-23 15:36pm    
"...What error message do you get when the problem occurs?..."

From an HTTPS site, my browsers report: "No Internet"

From an HTTP site, all is well, totally smooth sailing

I have vocabulary and protocol study in front of me, as I don't know about TLS1.2 //// Will click, read, and see if I can make any sense out of this.
Richard Deeming 6-Jan-23 4:34am    
Do you get an ERR_blah_blah code at the bottom of the page? That might yield more useful information. :)
C-P-User-3 6-Jan-23 7:26am    
"...Do you get an ERR_blah_blah code at the bottom of the page?..."

Sorry, Mr. Fail Expert here. Your brain is better than mine; duh; when will I remember to take screen caps ?

Lesson learned: if (probably "when") it happens next time, take a screen cap, and copy and paste what I can into my text editor.
C-P-User-3 5-Jan-23 15:39pm    
The link you provided has this blurb...

"...This article applies to Windows Server 2003 and earlier versions of Windows. For registry keys that apply to Windows Server 2008 and later versions of Windows, see the TLS Registry Settings...."

Is that relevant to my immediate concern ?

This content, along with any associated source code and files, is licensed under The Code Project Open License (CPOL)

CodeProject, 20 Bay Street, 11th Floor Toronto, Ontario, Canada M5J 2N8 +1 (416) 849-8900