Click here to Skip to main content
15,744,459 members
Please Sign up or sign in to vote.
0.00/5 (No votes)
See more:
When I tried to upload my CSV file that contains a value '00E1' showing a '0' value after uploading.

The 00E1 value is a Name, so I want it as '00E1' not a 0 value in Big Query.

For Eg -

1. I opened an Excel sheet, and format a column as Text.
2. I put my value as '00E1' and then Save it AS a CSV file.
3. Upload to Big Query and it shows as value '0.0'

Can you guys why it is showing 0.0 and how can I overcome this issue?

What I have tried:

I have tried adding a tab character with 00E1 and uploaded but not worked.
Richard MacCutchan 9-Feb-23 7:28am    
Since we cannot see the contents of your csv file, or what Big Query does to interpret the content, we cannot give a reasonable answer.
aravindnass 9-Feb-23 8:53am    
Thanks for the reply, I don't know how to add a screenshot to this. But I just open an excel added Name as a header and below I added 00E1. Then I Save AS to CSV format. Then I uploaded it to the BigQuery as CSV. So it shows 0.0.
Richard Deeming 9-Feb-23 8:54am    
At a guess, it's using something similar to Excel's CSV parsing, and thinks 00E1 is scientific notation for 0×10<sup>1</sup>, which is obviously just 0.

Assuming you've already put the value in double quotes, you could try adding a ' to the start, which usually sorts Excel out: "'00E1".
aravindnass 9-Feb-23 10:58am    
You are correct, but if I put "'00E1" and upload this to the BigQuery table, it will insert as '00E1. But I need to insert it as 00E1.

This content, along with any associated source code and files, is licensed under The Code Project Open License (CPOL)

CodeProject, 20 Bay Street, 11th Floor Toronto, Ontario, Canada M5J 2N8 +1 (416) 849-8900