Click here to Skip to main content
15,936,633 members
Please Sign up or sign in to vote.
0.00/5 (No votes)
Hi All,

I am currently working on a project where there are many .dll files to be read from the main application.

The other supportive projects are build successfully and the .dll files are also created. While running the main application, its not running at all and if I switch to Network tab of the Chrome Development Tools, its showing "Access Denied" for all those .dll files.

I am using windows 11 and all the projects are kept inside a folder within C: drive.

The Error am seeing:

Access denied: Restricted file type

File type: Windows Library File (dll)
Source: http://domain.local/_framework/Irony.dll

Your organization's policy restricts access to this file type.


What I have tried:

The folder in C: drive was showing read-only. I got the administrative privilege and so tried to remove read-only property for that folder and other sub-folders. Its showing that the read-only property has been removed but when am checking the folder again, its still showing read-only. But, all the files within that folder and sub-folders are not set as read-only.

I don't know if its due to this folder access restriction am seeing the error related to .dll files or something else.

Technically, those .dll files need to be read to run the main application and so if the folders are read-only, I guess its fine.

So, is there any other problem going on and is there any other way out to resolve this issue. Because, my other team members can be able to run the application locally and they also have all their projects in C: drive itself.
Posted
Comments
Richard MacCutchan 10-May-23 3:17am    
"Your organization's policy restricts access to this file type."
Talk to your system administrator about getting your policy restrictions eased.
Member 11072126 10-May-23 4:40am    
Actually, I have contacted the System Admin regarding this and he tried a lot to remove read-only access from the project folder within C: drive. We are using Windows 11 here and probably all the folders in C: drive are read-only by default.

And we cannot move the project folder to other drive because to run the project locally, the .aspx pages are put inside "www" folder within C: drive, running through IIS, and that's how the local setup is being done. So, I guess moving the project folder to other drive will be a problem.
Richard MacCutchan 10-May-23 5:12am    
This is still a problem that only your administrator can resolve, as clearly stated in the error message. There is no programming issue that anyone on this site can help with.
Member 11072126 10-May-23 5:42am    
Okay. Thanks.

This content, along with any associated source code and files, is licensed under The Code Project Open License (CPOL)



CodeProject, 20 Bay Street, 11th Floor Toronto, Ontario, Canada M5J 2N8 +1 (416) 849-8900