Click here to Skip to main content
15,941,071 members
Please Sign up or sign in to vote.
1.00/5 (2 votes)
See more:
Hi, I'm facing a problem when using Radxa Rock 3 Model A for KVM. It shows UDC file not found and 500 internal server error in the browser. I need some advice and help figuring out what I did wrong.


What I have tried:

I have tried few ways to configure the dtb file but it keep shown UDC file not found
Posted
Updated 13-Jun-23 23:20pm
Comments
Andre Oosthuizen 13-Jun-23 9:13am    
The answer lies in your question, the UDC file is not found - Is the path correct, does the file exist etc...
VincentLiew1027 13-Jun-23 9:15am    
I think I did all correctly, may I ask do you familiar with rock 3 Model A?
Andre Oosthuizen 13-Jun-23 9:18am    
Unfortunately not sorry. Maybe show us what you did and someone with knowledge on rock 3 Model A can assist. I found this, maybe it will help - can't find an available UDC[^]
VincentLiew1027 13-Jun-23 9:19am    
Sure I will paste the problems I face here
Andre Oosthuizen 13-Jun-23 9:24am    
I added a link to my previous comment, maybe it will help.

1 solution

As per my comments, I am not skilled in this field. Some Googling (a scarce subject this) gave some pointers, see my links below. I am however not sure where you should start looking, follow the links as it did cover a lot around UDC. It seems the problem is with your USB detection and not the file. It might help to reach out to the KVM community as they will be skilled in this field.

To cover both and from what I could gather for fault checking steps -
1. Check that the file is named correctly as 'UDC' and that it exists in the specified location. Make sure that you are providing the correct path to the file. Use the command 'ls' or 'dir' to list the files of the directory and verify that your file exist in the specified path/directory.
2. Make sure that you have appropriate permissions to read the file.
3. Make sure that your system has USB support enabled. Some virtualized environments or configurations might restrict or disable USB access.
4. Check that there are no UDC devices connected or available on the system. Ensure that the USB device you are trying to interact with is properly connected, powered on, and functioning correctly. Try connecting a different USB device to see if it can be detected by your code.
5. Check for any software or driver updates for the USB subsystem on your pc. Outdated or incompatible drivers could cause issues with UDC detection.
6. Use different USB devices or test the code on a different pc to determine if the issue is related to the code or your specific environment.

Google Returned Links To Assist In UDC Detection[^]
Change log for linux-kvm package[^]
 
Share this answer
 

This content, along with any associated source code and files, is licensed under The Code Project Open License (CPOL)



CodeProject, 20 Bay Street, 11th Floor Toronto, Ontario, Canada M5J 2N8 +1 (416) 849-8900