Click here to Skip to main content
13,553,325 members
Rate this:
Please Sign up or sign in to vote.
See more:
i see this error when building my project in VS2010. when i run it says .exe file is missing. build the project and retry. when i build again it same error given below appears. can anyone solve this? The project was downloaded from internet.

Error   1   The command ""C:\Program Files\Microsoft SDKs\Windows\v6.0A\bin\rc.exe"  /d USE_PNG  /i "C:\Program Files\Microsoft SDKs\Windows\v6.0A\Include"   /i "c:\Program Files\Microsoft Visual Studio 10.0\Common7\IDE\..\..\vc\include"   /r "C:\Users\spiro41\Downloads\SplashScreenSample_1_10_2009\win32res.rc"
" exited with code 3.   SplashScreenSample
Posted 29-Jan-13 22:45pm
Updated 13hrs ago
Andreas-Gieriet 30-Jan-13 6:09am
"What did you do before you did nothing?" ;-)
An empty project or did you add/modify some resources? rc.exe is the resource compiler.
There is most likely more error text. Have a look in the Output window of VS2010.
User-8494473 5-Feb-13 9:42am
i just downloaded from internet
Andreas-Gieriet 5-Feb-13 11:33am
See my solution below.
011111100010 30-Jan-13 8:42am
Look in the build options. It may be trying to do something extra.
Rate this: bad
Please Sign up or sign in to vote.

Solution 1

What is reported in the output window (not the error window) of VS2010?
What do you mean by ".exe file is missing"? Which exe file?

So, that means you build twics and you get different errors in each build?

Do these paths exist in your system:
- C:\Program Files\Microsoft SDKs\Windows\v6.0A\bin\rc.exe
- C:\Program Files\Microsoft SDKs\Windows\v6.0A\Include
- c:\Program Files\Microsoft Visual Studio 10.0\Common7\IDE\..\..\vc\include
- C:\Users\spiro41\Downloads\SplashScreenSample_1_10_2009\win32res.rc

As I said: there must be some text in the output window of VS2010.
Check that and give feedback if it helps.

User-8494473 25-Feb-13 7:23am
Instead of the following path-C:\Program Files\Microsoft SDKs\Windows\v6.0A\Include, the system has C:\Program Files\Microsoft SDKs\Windows\v7.0A\Include. I cant find any remedy. kindly help me.. i need to run that project
Andreas-Gieriet 25-Feb-13 7:38am
Do you have multiple versions of Visual Studio installed?
1) Open the Visual Studio Command Prompt from the start menu
2) check the location of the respective tools:
where rc.exe
3) if this fails or points to the wrong directory, check if you properly un-install former VisualStudio versions.

Maybe, also the csproj file contains absolute references. Open the respective csproj file in a text editor and search for the offending paths. Replace by the correct ones.

User-8494473 26-Feb-13 5:37am
i have visual studio 2010 professional
Setting environment for using Microsoft Visual Studio 2010 x86 tools.

c:\Program Files\Microsoft Visual Studio 10.0\VC>where rc.exe
c:\Program Files\Microsoft SDKs\Windows\v7.0A\bin\RC.Exe

c:\Program Files\Microsoft Visual Studio 10.0\VC>
i typed the command you said and i got the above output. kinly refer
Andreas-Gieriet 26-Feb-13 6:33am
And what's about the csproj file?
And absolute references there (open the csproj file in a text editor and search for v6.0a) or as Richard suggested: check the rc script content for that path entry)?
User-8494473 9-Mar-13 0:43am
To dear Andreas Gieriet. Thanks for your post.

i searched for v6.0a nut it didn't appear anywhere.i think there is no option to open and run that project bcos somewhere the old reference is appearing which i can' find.
kindly give me any possible options. if none of the ideas work i think i need to create a new one.

I used windows 7 powershell for the first time. I followed and typed the command given by you.
but it throwed the following message

Select-String : The file C:\Users\spiro41\Documents\Visual Studio 2010\Projects\12byte\12byte can not be read: Access t
o the path 'C:\Users\spiro41\Documents\Visual Studio 2010\Projects\12byte\12byte' is denied.
At line:1 char:35
+ gci . "*.*" -r | %{ select-string <<<< -path $_.fullname -patt 'v6.0a' }
+ CategoryInfo : InvalidArgument: (:) [Select-String], ArgumentException
+ FullyQualifiedErrorId : ProcessingFile,Microsoft.PowerShell.Commands.SelectStringCommand
Andreas-Gieriet 9-Mar-13 1:08am
1) open a powershell
2) cd to-your-project-root-dir
3) gci . "*.*" -r | %{ select-string -path $_.fullname -patt 'v6.0a' }
This lists the files that contain that v6.0a string.
User-8494473 16-Apr-13 7:14am
dear Andreas Gieriet, ple read my reply above.. kindly give some alternate
Andreas-Gieriet 16-Apr-13 13:08pm
You seem not to be at the right location in the directory tree. Where is your project located (what path)?
if you know that, do the step 2) as shown above and replace to-your-project-root-dir by that path.
The command line 3) also scanns binary files which cause this error message. To hide them, you can extend the command line as follows:
3) gci . "*.*" -r | %{ select-string -path $_.fullname -patt 'v6.0a' } 2>$null
Rate this: bad
Please Sign up or sign in to vote.

Solution 2

Look at the content of your resource script file win32res.rc and make sure there are no references to items that do not exist. Also check the project settings for the file, since it looks as if it is trying to find items in an old version of the SDK, and it uses a couple of very old options which are no longer valid.
Rate this: bad
Please Sign up or sign in to vote.

Solution 3

I had this same problem while trying to build the CSActiveX sample program. I basically ran the program from command line with the correct file paths but it still crashed saying it could not open file .../CSActiveX.rc. I made a blank text file in notepad, renamed to CSActiveX.rc and saved in the target path in the command. This time it worked. I think it will only compile to a file already exiting and won't create a new one the very first time.

This content, along with any associated source code and files, is licensed under The Code Project Open License (CPOL)

  Print Answers RSS
Top Experts
Last 24hrsThis month

Advertise | Privacy |
Web01 | 2.8.180515.1 | Last Updated 22 May 2018
Copyright © CodeProject, 1999-2018
All Rights Reserved. Terms of Service
Layout: fixed | fluid

CodeProject, 503-250 Ferrand Drive Toronto Ontario, M3C 3G8 Canada +1 416-849-8900 x 100