Click here to Skip to main content
15,947,958 members
Please Sign up or sign in to vote.
1.00/5 (2 votes)
See more:
My .NetFramework version does not work with my Microsoft.SharePointClient.dll version.  Which version  should I use?

I am trying to add some CSOM functionality to my C# program such that I will be allowed to do CRUD operations on a Microsoft List (aka SharePoint List).  Assuming you know what CSOM and CRUD is, I will not bore you with the details of the specifics.  The end result of adding the references to the DLLS and the proper namespace, I get an error in my IDE:

> "Could not install package 'Microsoft.SharePoint.Client.dll
> 15.0.4420.1017'. You are trying to install this package into a project that targets '.NETFramework,Version=v4.7.2', but the package does not
> contain any assembly references or content files that are compatible
> with that framework. For more information, contact the package
> author."

And so, I have two questions:

What .NetFramework version is compatible  with Microsoft.SharePoint.Client.dll 15.0.4420.1017 ?
(question 1)

What Microsoft.SharePoint.Client.dll version is compatible  with .NETFramework Version=v4.7.2 ?
(question 2)


What I have tried:

I was following a tutorial. I added the DLL as a reference and I included the proper namespace when I got this error
Posted
Comments
Dave Kreskowiak 11-Jun-24 11:06am    
You're following an OLD tutorial.

1 solution

You already asked this question here[^]. You already know that the version you picked is targeted for a much earlier version of .NET, and that this isn't an official release. If you have additional questions, it's common courtesy to ask for clarifications on your original question; not to post a new largely duplicated one.
 
Share this answer
 

This content, along with any associated source code and files, is licensed under The Code Project Open License (CPOL)



CodeProject, 20 Bay Street, 11th Floor Toronto, Ontario, Canada M5J 2N8 +1 (416) 849-8900