Click here to Skip to main content
14,176,616 members
Rate this:
 
Please Sign up or sign in to vote.
See more:
<Rad:RadButton ID="Ok" runat="server" Text="Submit" Style="display: block;"   ValidationGroup="Name1"  OnClick="Ok_Click" CausesValidation="false"  />

                             <Rad:RadButton ID="Update" runat="server" Text="Update" Style="display: none;"  ValidationGroup="Name1" OnClick="Update_Click" />


In the above code i am having two button controls with validationgroup whenever i am clicking ok onclick button .The onclick event is not firing.
Posted
Comments
Prasad Khandekar 9-Apr-13 4:04am
   
Hello Sreedhar,

Do you mean to say that the Update_Click server side handler is not getting called? Have you tried setting the AutoPostBack property to true?

Regards,
Chinmaya_Champatiray 9-Apr-13 4:25am
   
You have specified ValidationGroup="Name1". So please check if any client validation fails.
vaibhav10Dec1987 12-Apr-13 6:27am
   
Use property autopostback="true".

1 solution

Rate this: bad
 
good
Please Sign up or sign in to vote.

Solution 1

try this:


1) AutoPostback="true"
2) check whether validation is failed,
   

This content, along with any associated source code and files, is licensed under The Code Project Open License (CPOL)

  Print Answers RSS
Top Experts
Last 24hrsThis month


Advertise | Privacy | Cookies | Terms of Service
Web01 | 2.8.190525.1 | Last Updated 16 Apr 2013
Copyright © CodeProject, 1999-2019
All Rights Reserved.
Layout: fixed | fluid

CodeProject, 503-250 Ferrand Drive Toronto Ontario, M3C 3G8 Canada +1 416-849-8900 x 100