Click here to Skip to main content
14,843,256 members
Please Sign up or sign in to vote.
1.80/5 (2 votes)
See more: , +
My project is in .Net 4 and works good,
But in setup project i got some errors like this:
Warning 2 The 'SAP Crystal Reports Runtime Engine for .NET Framework' item selected requires 'Microsoft.Data.Access.Components.2.8'. Select the missing prerequisite in the Prerequisites Dialog Box or create a bootstrapper package for the missing prerequisite.

Error 4 The install location for prerequisites has not been set to 'component vendor's web site' and the file 'Crystal Reports for .NET Framework 4.0\CRRuntime_32bit_13_0_5.msi' in item 'SAP Crystal Reports Runtime Engine for .NET Framework' can not be located on disk. See Help for more information.

and building faild!!
also my app.config is:
XML
<?xml version="1.0"?>
<configuration>
<configSections>
</configSections>
<connectionStrings>
    <add name="vam.Properties.Settings.vamConnection" connectionString="Data Source=.\SQLEXPRESS;AttachDbFilename=G:\vam\vam\bin\Debug\vam.mdf;Integrated Security=True;Connect Timeout=30;User Instance=True" providerName="System.Data.SqlClient"/>
</connectionStrings>
<startup useLegacyV2RuntimeActivationPolicy="true"><supportedRuntime version="v4.0" sku=".NETFramework,Version=v4.0"/></startup></configuration>



please help
Posted
Updated 4-May-13 6:14am
v2
Comments
   
Are you getting any kind of Errors or Exceptions ?
Which Operating System are you using ?
FM7 12-Apr-13 14:30pm
   
too much errors!
i use win 7
[no name] 4-May-13 12:21pm
   
Help for what? The warning and the error tell you exactly what is wrong and how to fix it.

Just make sure to add this in your app.config file. and then it should work.
HTML
<startup useLegacyV2RuntimeActivationPolicy="true">
        <supportedRuntime version="v4.0"/>
    </startup>
   
v3
Comments
FM7 13-Apr-13 19:18pm
   
very very very good my friend.it works good.thanks.
it was very simple but i didn't know.
Now for create setup i got following errors:
Warning 3 Item 'Windows Installer 4.5' is required by 'SQL Server 2008 Express', but was not included.
Warning 4 One of the following items 'Microsoft .NET Framework 4 (x86 and x64), .NET Framework 3.5 SP1' is required by 'SQL Server 2008 Express', but none were included.
Warning 2 The 'SAP Crystal Reports Runtime Engine for .NET Framework' item selected requires 'Microsoft.Data.Access.Components.2.8'. Select the missing prerequisite in the Prerequisites Dialog Box or create a bootstrapper package for the missing prerequisite.
Warning 1 The 'SAP Crystal Reports Runtime Engine for .NET Framework' item selected requires 'Microsoft.Net.Framework.2.0'. Select the missing prerequisite in the Prerequisites Dialog Box or create a bootstrapper package for the missing prerequisite.
Error 5 The install location for prerequisites has not been set to 'component vendor's web site' and the file 'Crystal Reports for .NET Framework 4.0\CRRuntime_32bit_13_0_5.msi' in item 'SAP Crystal Reports Runtime Engine for .NET Framework' can not be located on disk. See Help for more information.
Error 6 The install location for prerequisites has not been set to 'component vendor's web site' and the file 'Crystal Reports for .NET Framework 4.0\CRRuntime_64bit_13_0_5.msi' in item 'SAP Crystal Reports Runtime Engine for .NET Framework' can not be located on disk. See Help for more information.

can you help me?please
Raj Parashar 14-Apr-13 3:59am
   
These are all setup prerequisite errors which you can find by right click on tne setup project and click properties and u will find prerequisite button overthere. click on the button and select all prerequisite required by your application and select

download prerequisite from the same location as my application

and build your project which will copy all of your application required tools to the same location as setup and then i guess there shouldn't be any error.
CRRuntime_32bit_13_0_5.msi install it on client system it will work fine..
   
Hi, right click on your project and go to properties..and then change the Target framework form .Net framework 4 client profile to .Net framework 4...
   
v2
Comments
FM7 12-Apr-13 14:32pm
   
both of them not work!
Dilan Shaminda 12-Apr-13 22:10pm
   
did u config the app.config file as mentioned in the above solution?

This content, along with any associated source code and files, is licensed under The Code Project Open License (CPOL)

  Print Answers RSS
Top Experts
Last 24hrsThis month



CodeProject, 20 Bay Street, 11th Floor Toronto, Ontario, Canada M5J 2N8 +1 (416) 849-8900