Click here to Skip to main content
15,947,785 members
Please Sign up or sign in to vote.
2.60/5 (3 votes)
Hi,
I'm stuck with some administrative permission.. I want to change the setting for guest account to prevent using some application on system, then i found some tips on google and tried that..
the tips is -:
Allow Users To Run Only Specified Programs in Windows 7

If you have a shared or public computer you might want to allow users to use only specified programs. Today we take a look at a setting in Local Group Policy that allows you to set only specified programs to run.

Note: This process uses Local Group Policy Editor which is not available in Home versions of Windows 7.

First click on Start and enter gpedit.msc into the search box and hit Enter.
Navigate to User Configuration \ Administrative Templates \ System. Then under Setting scroll down and double click on Run only specified Windows applications.
Set it to Enabled, then under the Options section click on the Show button next to List of allowed applications.
A Show Contents dialog comes up where you can type in the apps you want to allow users to run. When finished with the list, click OK then close out of Local Group Policy Editor.
(Here I just add one program to that list which is "TeraCopy.exe").

If a user tries to access an application that is not on the specified list they will receive the following error message.

After that I can open only "teraCopy" application, even I can't open the "gpedit.msc", so can't change that settings..

Please Help me Out..

I'm sorry, I know this is not the right place for posting this question...
Posted
Updated 28-Apr-13 2:11am
v3
Comments
Sergey Alexandrovich Kryukov 28-Apr-13 13:48pm    
Off-topic. Maybe you should pick some other site.
—SA

1 solution

Although off-topic, this link may help you: http://social.technet.microsoft.com/Forums/en-US/winserverGP/thread/2aa2e0ff-85aa-4ac0-ad62-78af95d93849/[^].

The tip you found in the net misses a warning that should be placed in big letters on the top:

WARNING:
You may lock yourself when not allowing access to GPEdit (mmc.exe) or regedit.exe.
 
Share this answer
 
Comments
JayantaChatterjee 29-Apr-13 10:50am    
Thanks for helping me...
My friend solved it... :-)

This content, along with any associated source code and files, is licensed under The Code Project Open License (CPOL)



CodeProject, 20 Bay Street, 11th Floor Toronto, Ontario, Canada M5J 2N8 +1 (416) 849-8900