Click here to Skip to main content
13,191,400 members (71,337 online)
Rate this:
 
Please Sign up or sign in to vote.
See more:
<wsHttpBinding>
          <binding name="wsHttpBinding_https" bypassProxyOnLocal="false" transactionFlow="false" hostNameComparisonMode="StrongWildcard" maxBufferPoolSize="524288" maxReceivedMessageSize="65536" messageEncoding="Text" textEncoding="utf-8" useDefaultWebProxy="true" allowCookies="false">
            <reliableSession ordered="true" inactivityTimeout="00:10:00" enabled="false"/>
            <!--<security mode="Message">-->
            <security mode="Transport">
              <transport clientCredentialType="Windows"/>
            </security>
          </binding>
        </wsHttpBinding>
      </bindings>
    <services>
      <service behaviorConfiguration="RegistrationUserBehavior" name="UserInformationAPI.Service.Library.RegistrationUserLibrary">
        <endpoint address="https://localhost:4588/UserInformationAPI.Service.Host/RegistrationUser.svc" binding="wsHttpBinding" contract="UserInformationAPI.Service.Contract.IRegistrationUser" bindingConfiguration="wsHttpBinding_https">
          <identity>
            <dns value="localhost" />
          </identity>
        </endpoint>
        <endpoint address="mex" binding="mexHttpsBinding" contract="IMetadataExchange" />
      </service>
    </services>
    <behaviors>
      <serviceBehaviors>
        <behavior name="RegistrationUserBehavior">
          <serviceMetadata httpsGetEnabled="true" httpsGetUrl="https://localhost:4588/UserInformationAPI.Service.Host/RegistrationUser.svc/wsdl" />
          <serviceDebug includeExceptionDetailInFaults="true"/>
        </behavior>
      </serviceBehaviors>
    </behaviors>
Posted 27-Jun-13 1:08am
Comments
sureshsankar 27-Jun-13 7:10am
   
help with me friends
Rate this: bad
 
good
Please Sign up or sign in to vote.

Solution 1

have you enabled Https in config file?

<servicemetadata httpsgetenabled="true" />
  Permalink  
Comments
sureshsankar 27-Jun-13 7:40am
   
Yes I have hosted in Https in config file,So how to solve below error
Could not find a base address that matches scheme https for the endpoint with binding WebHttpBinding. Registered base address schemes are [http]
ArunRajendra 28-Jun-13 2:18am
   
Can you post the full web.config file
Rate this: bad
 
good
Please Sign up or sign in to vote.

Solution 2

You would need to enable SSL on IIS to accept https connections.
You can do that in IIS Control panel ( of the server where you are hosting this service) and enable SSL
  Permalink  

This content, along with any associated source code and files, is licensed under The Code Project Open License (CPOL)

  Print Answers RSS
Top Experts
Last 24hrsThis month


Advertise | Privacy |
Web04 | 2.8.171017.1 | Last Updated 3 Jan 2014
Copyright © CodeProject, 1999-2017
All Rights Reserved. Terms of Service
Layout: fixed | fluid

CodeProject, 503-250 Ferrand Drive Toronto Ontario, M3C 3G8 Canada +1 416-849-8900 x 100