Click here to Skip to main content
15,947,958 members
Please Sign up or sign in to vote.
0.00/5 (No votes)
See more: , +
Hi ,


I'm writing a user control for my c# application using VS2012 . When I'm adding another windows forms application project to same solution which I created the user control , the user control is showing up on the toolbox window and user control is working fine.But when I create individual project and add reference to .dll file I could not load the user control to toolbox.When I try to add the following message is showing :

"There are no component in <.dll path> that can be placed on the toolbox".

but actually there is a user control inside that dll .


What could be the possible problem ? please help ...
Posted
Updated 6-Dec-16 4:22am

I've solved it at last :D

The problem was my dll file haven't a strong name.

I followed these links to solve this problem

First I created a new user control

http://msdn.microsoft.com/en-us/library/9yxtkx75(v=vs.85).aspx[^]

Then I looked into the following link to add my control to toolbox window

http://msdn.microsoft.com/en-us/library/9yxtkx75(v=vs.85).aspx[^]

From that link I learned that I should Install my control assembly to the Global Assembly Cache

http://msdn.microsoft.com/en-us/library/dkkx7f79(v=vs.110).aspx

To add to global assembly cache I need to assign a strong name to the dll
http://msdn.microsoft.com/en-us/library/h4fa028b(v=vs.100).aspx[^]


I did that and solved my problem ...
 
Share this answer
 
v2
Add the dll, reference it
Compile the project
Save the solution and restart visual studio
 
Share this answer
 
Comments
Jackson K T 1-Jul-13 0:51am    
I tried this before posting this question.Not working :( ...

This content, along with any associated source code and files, is licensed under The Code Project Open License (CPOL)



CodeProject, 20 Bay Street, 11th Floor Toronto, Ontario, Canada M5J 2N8 +1 (416) 849-8900