Click here to Skip to main content
14,661,076 members
Rate this:
Please Sign up or sign in to vote.
See more:
Hi,
i am developing a web site using vs 2010.it uses a external dll , which is written on VBA(VB6).
when i add the dll reference and debug the application(http://localhost:58554/myapp),i got the expected output .when i configure it in iis(http://localhost/myapp) and browse the output is differ. I am using the same coding same dll reference. where will be the error ?

Thanks
Posted
Comments
Sushil Mate 12-Jul-13 6:43am
   
you need to elaborate more? what dll are you speaking of? what kind of output you are getting?
John Sathish Tamilarasu 12-Jul-13 6:51am
   
The dll i am using is our own business logic dll. it is working good with vb applications. now i am migrating the vb application to web app. a specific function should return month days=30. when i debug the application it returns 30.when i configure the app in iis and browse it returns month days=1. but there is no code change and dll change.what is the issue?
Sushil Mate 12-Jul-13 6:57am
   
I guess problem lies in the dll logic. can you show us the dll code?
SIJUTHOMASP 12-Jul-13 8:19am
   
Is your dll is directly referenced and taken from bin only or do you have any reference in web.config to take it from GAC ? If do you have any old version dll in GAC which is referenced while you accessed it from IIS. Do you have any scenarios like that.
ZurdoDev 12-Jul-13 12:05pm
   
Where's the error? How can we know. There is not just one possibility for your scenario. You need to post code, error messages, more detail.

This content, along with any associated source code and files, is licensed under The Code Project Open License (CPOL)




CodeProject, 503-250 Ferrand Drive Toronto Ontario, M3C 3G8 Canada +1 416-849-8900 x 100