Click here to Skip to main content
12,999,744 members (45,003 online)
Rate this:
 
Please Sign up or sign in to vote.
See more:
I am trying to run a project on my system (the project is in mvc and azure ). i am able to build the project but it is showing error on run time .the error message is as following :-

Could not load file or assembly 'System.Net.Http, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a' or one of its dependencies. The located assembly's manifest definition does not match the assembly reference. (Exception from HRESULT: 0x80131040)
Posted 25-Jul-13 20:37pm
Rate this: bad
 
good
Please Sign up or sign in to vote.

Solution 1

Please try to add reference to the assembly explicitly.

Right click your Project -> Add Reference

Hope that helps. :)
  Permalink  
Comments
ashwnai kumar pandey 26-Jul-13 3:00am
   
but there are about more than 8 projects how to add and where i have tried to remove system.web.http.dll and add it again but still nit working and throwing same error .
Thanks
Rate this: bad
 
good
Please Sign up or sign in to vote.

Solution 2

Please see if you can find the assembly 'System.Net.Http', Version=2.0.0.0 in the GAC. I guess the version referenced by your project doesn't match with that present in the GAC.

In your solution, try to locate the project where you have referenced the assembly System.Net.Http.

You will have make sure the versions referenced and that in the GAC match.
  Permalink  
Rate this: bad
 
good
Please Sign up or sign in to vote.

Solution 3

There is version problem.So Add Reference again of System.Net.Http
  Permalink  

This content, along with any associated source code and files, is licensed under The Code Project Open License (CPOL)

  Print Answers RSS
Top Experts
Last 24hrsThis month


Advertise | Privacy | Mobile
Web02 | 2.8.170624.1 | Last Updated 26 Jul 2013
Copyright © CodeProject, 1999-2017
All Rights Reserved. Terms of Service
Layout: fixed | fluid

CodeProject, 503-250 Ferrand Drive Toronto Ontario, M3C 3G8 Canada +1 416-849-8900 x 100