Click here to Skip to main content
14,453,145 members
Rate this:
Please Sign up or sign in to vote.
See more: , +
Hi Chaps,

My problem is happening in running an exe from SSIS execute Process task.

I have an exe (.NET console application) which will replace text in a given word template and place a file in a server's shared folder.This exe is created using VS2008(32 bit Windows 20003 server) and its running only if word is installed in the server.

I am running this exe using SSIS in my preproduction server which is 64 bit Windows 2008 R2 server, so while executing .exe its throwing this error: Retrieving the COM class factory for component with CLSID {000209FF-0000-0000-C000-000000000046} failed due to the following error: 80040154. The process exit code was "-532459699"

I have tried few suggestion guided in forums like changing some thing in registry or adding interop.word dll in the server nothing worked out well.

Can anyone ever had this issue? Need your assistance on this...

Thanks in advance !!
Posted
Comments
[no name] 24-Sep-13 8:40am
   
Did you try registering the COM component?
venkatesun 24-Sep-13 9:03am
   
You mean to say register via regedit?If not, how to register it. Could you please provide me the steps to do that?
[no name] 24-Sep-13 10:42am
   
No I mean registering the component using regsvr32.exe.

This content, along with any associated source code and files, is licensed under The Code Project Open License (CPOL)




CodeProject, 503-250 Ferrand Drive Toronto Ontario, M3C 3G8 Canada +1 416-849-8900 x 100