Click here to Skip to main content
15,067,335 members
Please Sign up or sign in to vote.
0.00/5 (No votes)
hi to all ,
i have a problem ... i want to create a login user for my database ..

For this i did the following process ...

1. In server explorer i go on "Security" and then on "Login" and then on right click "New Login"

2. In "general" tab i set a "Login name" . and check "sql server authentication" and set passward

3. Then in "Default database" i select "master" and in "default language" i set "english"

4 In server roles ... check all roles

5. in "user mapping " i select database for which i want to create login user .

6. And in "status" grant permision and enable login .

7. And then click ok .



But this is not working. when i try to login , it says ...

"A connection was successfully established with the server, but then an error occurred during the login process. (provider: Shared Memory Provider, error: 0 - No process is on the other end of the pipe.) (Microsoft SQL Server, Error: 233)"


and then i also enable namedpipe in sql server configuration manager ..

but it gives the same error ... pls give suggetion .. where i am wrong in my process.. ?
Posted
Comments
GDdixit 30-Oct-13 5:44am
   
i have checked . it is selected as "sql server and windows authentication mode"
sp_suresh 30-Oct-13 5:56am
   
Please go through
http://blog.sqlauthority.com/2009/05/21/sql-server-fix-error-provider-named-pipes-provider-error-40-could-not-open-a-connection-to-sql-server-microsoft-sql-server-error/
and
http://msdn.microsoft.com/en-us/library/ms175496(v=sql.110).aspx also

Make sure that SQL SERVER service is running.
You can enable/start SQL Server service by doing following steps.

Go to Control Panel >> Administrative Tools >> Services >>
Find SQL SERVER(MSSQLSERVER) >> Right Click >> Properties >> Startup Type Automatic & Click Start.
   
Be sure that the server is ready to accept remote connections.

It's not enabled by default.
   
Comments
GDdixit 30-Oct-13 5:44am
   
where can i check this frnd ?
GDdixit 30-Oct-13 5:48am
   
ok i have seeing this . this is already checked in property
in addition to the whole previous make sure that the firewall is turned off if you connect to that database on another PC

and after creating the user don't forget to restart your server
right click on the server and choose restart
   
v2

This content, along with any associated source code and files, is licensed under The Code Project Open License (CPOL)




CodeProject, 20 Bay Street, 11th Floor Toronto, Ontario, Canada M5J 2N8 +1 (416) 849-8900