Click here to Skip to main content
15,041,264 members
Please Sign up or sign in to vote.
0.00/5 (No votes)
See more:
Arghhhhh!!!

Can someone explain this for me? I want to use a custom user control from one project in the design view of a form in another project in the same solution. So, I think to myself, OK I'll add the control to the toolbox (no problem there, I either use the 'Choose Toolbox Items' option or I drag the assembly onto the toolbox) and then I drag the control on to my form. Simple. Why oh why doesn't the control on the form update when I make changes to the control class after it's been added to the form? I added some properties to the control but they aren't offered up to me in the properties box when I select the control on the form. I thought I'd try to get around it by adding the code into the designer file (I know I shouldn't but bear with me) and it compiled fine, but when I try to view the form in design view I get a bunch of warnings telling me those properties don't exits (even though it compiles!!!) X| X| X|

I'm thinking it somehow retains the assembly version for that particular control for the designer but I can't find that anywhere. It's driving me nuts!
Posted

1 solution

My bad. My project reference wasn't copying locally (which is where I guess it gets the designer definition from).
   

This content, along with any associated source code and files, is licensed under The Code Project Open License (CPOL)




CodeProject, 20 Bay Street, 11th Floor Toronto, Ontario, Canada M5J 2N8 +1 (416) 849-8900