Click here to Skip to main content
15,399,788 members
Please Sign up or sign in to vote.
0.00/5 (No votes)
See more:
Hi Friends,

one more query

when i click link on which is call Grid control, it shows the following exception

Exception:
Could not load file or assembly 'ComponentArt.Web.UI' or one of its dependencies. The system cannot find the file specified.


XML
Line 1:  <%@ Page Title="" Language="C#" MasterPageFile="~/InnerPageMaster.Master" AutoEventWireup="true" CodeBehind="Events.aspx.cs" Inherits="Temple.Web.Events" %>
Line 2:  <%@ Register TagPrefix="ComponentArt" Namespace="ComponentArt.Web.UI" Assembly="ComponentArt.Web.UI" %>
Line 3:  <%@ Register TagPrefix="Temple" TagName="SubMenus" Src="~/SubMenus.ascx" %>
Line 4:  <asp:Content ID="Content1" ContentPlaceHolderID="cpInnerPageMasterContent" runat="server">

Source File: /Events.aspx    Line: 2

Assembly Load Trace: The following information can be helpful to determine why the assembly 'ComponentArt.Web.UI' could not be loaded.


=== Pre-bind state information ===
LOG: User = SYSTEM3\Tishan Soft
LOG: DisplayName = ComponentArt.Web.UI
 (Partial)
WRN: Partial binding information was supplied for an assembly:
WRN: Assembly Name: ComponentArt.Web.UI | Domain ID: 3
WRN: A partial bind occurs when only part of the assembly display name is provided.
WRN: This might result in the binder loading an incorrect assembly.
WRN: It is recommended to provide a fully specified textual identity for the assembly,
WRN: that consists of the simple name, version, culture, and public key token.
WRN: See whitepaper http://go.microsoft.com/fwlink/?LinkId=109270 for more information and common solutions to this issue.
LOG: Appbase = file:///D:/Projects/Temple/Temple V3(latest)/Temple.Web/
LOG: Initial PrivatePath = D:\Projects\Temple\Temple V3(latest)\Temple.Web\bin
Calling assembly : (Unknown).
===
LOG: This bind starts in default load context.
LOG: Using application configuration file: D:\Projects\Temple\Temple V3(latest)\Temple.Web\web.config
LOG: Using host configuration file:
LOG: Using machine configuration file from C:\Windows\Microsoft.NET\Framework\v4.0.30319\config\machine.config.
LOG: Policy not being applied to reference at this time (private, custom, partial, or location-based assembly bind).
LOG: The same bind was seen before, and was failed with hr = 0x80070002.
Posted
Comments
tgrt 28-Nov-13 13:10pm
   
Make sure the assembly is in the discovery path first. Next use the assembly binding log viewer (fuslogvw.exe) to determine exactly what is happening.

Here's the help topic that talks about using it: http://msdn.microsoft.com/en-us/library/e74a18c4(v=vs.110).aspx

1 solution

This content, along with any associated source code and files, is licensed under The Code Project Open License (CPOL)

  Print Answers RSS
Top Experts
Last 24hrsThis month


CodeProject, 20 Bay Street, 11th Floor Toronto, Ontario, Canada M5J 2N8 +1 (416) 849-8900