Click here to Skip to main content
15,434,147 members
Please Sign up or sign in to vote.
0.00/5 (No votes)
See more:
CSS
HTTP Error 403.14 - Forbidden
The Web server is configured to not list the contents of this directory.
Most likely causes:

    A default document is not configured for the requested URL, and directory browsing is not enabled on the server.

Things you can try:

    If you do not want to enable directory browsing, ensure that a default document is configured and that the file exists.
    Enable directory browsing.
        Go to the IIS Express install directory.
        Run appcmd set config /section:system.webServer/directoryBrowse /enabled:true to enable directory browsing at the server level.
        Run appcmd set config ["SITE_NAME"] /section:system.webServer/directoryBrowse /enabled:true to enable directory browsing at the site level.
    Verify that the configuration/system.webServer/directoryBrowse@enabled attribute is set to true in the site or application configuration file.

Detailed Error Information:
Module     DirectoryListingModule
Notification       ExecuteRequestHandler
Handler    StaticFile
Error Code     0x00000000
Requested URL      http://localhost:50746/
Physical Path      C:\Users\Ashwini\Desktop\WebSite8
Logon Method       Anonymous
Logon User     Anonymous
Request Tracing Directory      C:\Users\Ashwini\Documents\IISExpress\TraceLogFiles\WEBSITE8
More Information:
This error occurs when a document is not specified in the URL, no default document is specified for the Web site or application, and directory listing is not enabled for the Web site or application. This setting may be disabled on purpose to secure the contents of the server.

View more information »
Posted

You try to access the content of a web site via directory browsing. It's forbidden (mostly by default) for the site.
Possibly you have no default page declared on the side (no pages at all?).
You can also resolve it by adding a page name to the url - http://localhost/default.aspx...
 
Share this answer
 
enable the Directory Browsing option in
IIS-->Website/Virtual Directory Properties-->Enable Directory Browsing option
 
Share this answer
 
Comments
Kornfeld Eliyahu Peter 20-Jan-14 5:57am     CRLF
It's a possible solution, however I would not advise to publish any web site with Directory Browsing enabled. If you want to show content of directories, better use some page with proper control on it...

This content, along with any associated source code and files, is licensed under The Code Project Open License (CPOL)



CodeProject, 20 Bay Street, 11th Floor Toronto, Ontario, Canada M5J 2N8 +1 (416) 849-8900