Click here to Skip to main content
13,898,182 members
Rate this:
 
Please Sign up or sign in to vote.
I am trying to connect sql server 2008 R2. But it gives

A network related or instance specific error has occurred while establishing a connection to the server. The server was not found or was inaccessible. Verify that the instance name is correct and that SQL Server is configured to allow remote connections. (provider: TCP Provider, error: 0 - No connection could be made because the target machine actively refused it.) (Microsoft SQL Server, Error: 10061)


I enabled Client Protocols from Configuration Manager .Still Not Working. Please Help.
Thanks In Advance
Posted
Updated 27-Feb-14 20:05pm
v2
Comments
Vedat Ozan Oner 28-Feb-14 2:07am
   
have you tried connecting with ssms?
pradnyaa 28-Feb-14 2:33am
   
Yes but still the same
Tejas Vaishnav 28-Feb-14 2:08am
   
the error message it self shows that, your sqlserver is not available or inaccessible. so please check that, your sql server instance name is correct or not? if it is correct then check, sql browsing service is running or not and tcp/ip protocol is enable for sql browsing over network or not?
pradnyaa 28-Feb-14 2:21am
   
Sql Server Agent is not running rest all services are running.
But when I tried to start it gives an error that the request failed or service did not respond in timely fashion. WHat do I do now?
Bernhard Hiller 28-Feb-14 2:32am
   
Did you try to access it from the computer where the service is running, or from a different computer?
pradnyaa 28-Feb-14 2:34am
   
No its in the same computer
Vedat Ozan Oner 28-Feb-14 2:51am
   
are you sure about the instance name? for example, when I try to connect to default instance (localhost), I'm receiving the same error since there exists no default. But when I connect to the named instance (localhost\sqlexpress), it is ok. moreover, you can try 'Windows Authentication' instead of server authentication.
pradnyaa 28-Feb-14 4:23am
   
Not working .I even tried using the IP address but stil the same. Once the service is stopped it does not start.
Vedat Ozan Oner 28-Feb-14 5:03am
   
assuming that you are talking about 'SQL Server' service, it makes sense not to be able to connect it. see event viewer (eventvwr) logs, sql server logs (which can be found in service startup parameters) to understand what happens with the service. without finding the actual cause, you cannot start the service (or you must be lucky which contradicts with Murphy).
pradnyaa 28-Feb-14 6:06am
   
Failed to initialize SQLSQM timer. One of the following can be the source of the problem: registry doesn't contain all necessary information, server instance name can not be retrieved correctly, failure during timer creation, etc.


This is the error in event log file
Vedat Ozan Oner 28-Feb-14 6:17am
   
now, you can google it :)

1 solution

This content, along with any associated source code and files, is licensed under The Code Project Open License (CPOL)

  Print Answers RSS
Top Experts
Last 24hrsThis month


Advertise | Privacy | Cookies | Terms of Service
Web02 | 2.8.190306.1 | Last Updated 28 Feb 2014
Copyright © CodeProject, 1999-2019
All Rights Reserved.
Layout: fixed | fluid

CodeProject, 503-250 Ferrand Drive Toronto Ontario, M3C 3G8 Canada +1 416-849-8900 x 100