Click here to Skip to main content
15,946,988 members
Please Sign up or sign in to vote.
0.00/5 (No votes)
See more:
Hi friends,

When I try to install the .NET framework 2.0 SP2 (.exe), it gives me following error:

MSIL
You must install Windows Installer 3.1 to complete installation. Microsoft .NET Framework 3.5 requires that Windows Installer 3.1 be installed prior to the installation.


[Screenshot][^]

I know that I should install Windows installer before trying to install the framework, but why the error message talks about Microsoft .NET Framework 3.5, not 2.0?

Thanks a lot.
s.john
Posted

have you checked that the framework to be installed as pre-requisite is V2.0 and not 3.5? Which version of .Net you used to create installer?

Just check if it's configured somewhere for V3.5 to be installed.
 
Share this answer
 
I am sorry if my question wasn't clear enough, but all I wanted is just install the .NET framework 2.0 SP2 in a clean Windows XP machine. So I downloaded the installer from Microsoft website and ran it - which gave me the above error!
 
Share this answer
 
Your Windows Installer version may be lower than 3.1. download 3.1 version. May be this will help u... :)
 
Share this answer
 

This content, along with any associated source code and files, is licensed under The Code Project Open License (CPOL)



CodeProject, 20 Bay Street, 11th Floor Toronto, Ontario, Canada M5J 2N8 +1 (416) 849-8900