Click here to Skip to main content
15,125,104 members
Please Sign up or sign in to vote.
0.00/5 (No votes)
See more:
Hi

In rdlc report,using the footer would leave that amount of space reserved on every page,

a white space on all pages except the last of each document where the contents of the footer would not be hidden.

Please give me a solution for eliminate white space where no footer.

Thanks
Posted
Updated 10-Apr-14 20:39pm
v5

1 solution

First: In your Footer property set height to 0in.
Second- don't use the build-in Footer. Instead, use a sub-report that will contain your footer details.
Now, you need to define the sub-report as thin as possible in the main report (while in the actual sub-report - arrange your data as you want).
now add a page footer(in your sub report) you should right-click on the design surface, point to Insert, and then click Footer (Or it can be enabled through the Report menu –> Add page footer in BIDS ).
You could put the rectangle into a page footer and set its Hidden property to:
VB
=Globals.PageNumber<Globals.TotalPages

Strech the rectangle to cover all the footer area, then your are good - the footer will not be displayed until the last page.
I think it will resolve your purpose.
   
v2
Comments
Rahul R Sutar 26-Apr-17 7:19am
   
How to set parameters to the subreport that is in the footer section ?? I have static values as a parameter(no datasource)
Member 14154034 18-Feb-19 6:02am
   
Sub report footer is completely ignored, whatever you place on sub report footer doesn't change anything. I don't understand how this solves the mentioned problem. Do you
Member 14631050 3-Dec-20 0:35am
   
Thanks. It worked for me

This content, along with any associated source code and files, is licensed under The Code Project Open License (CPOL)




CodeProject, 20 Bay Street, 11th Floor Toronto, Ontario, Canada M5J 2N8 +1 (416) 849-8900