Click here to Skip to main content
15,071,635 members
Please Sign up or sign in to vote.
0.00/5 (No votes)
See more:
I saw a error when open the web page in local host,and I repair MicroSoft .Net FrameFrame 2.
Now I can open the website in Localhost.
and I uploaded to Server using FTP .
When I am typing the web address and enter the homepage then show a error as below
The page cannot be found The page you are looking for might have been removed, had its name changed, or is temporarily unavailable. Please try the following: * Make sure that the Web site address displayed in the address bar of your browser is spelled and formatted correctly. * If you reached this page by clicking a link, contact the Web site administrator to alert them that the link is incorrectly formatted. * Click the Back button to try another link. HTTP Error 404 - File or directory not found. Internet Information Services (IIS) Technical Information (for support personnel) * Go to Microsoft Product Support Services and perform a title search for the words HTTP and 404. * Open IIS Help, which is accessible in IIS Manager (inetmgr), and search for topics titled Web Site Setup, Common Administrative Tasks, and About Custom Error Messages.

[edit]Title changed to be more meaningful - OriginalGriff[/edit]

My web config file is
XML
<?xml version="1.0"?>
<!--
    Note: As an alternative to hand editing this file you can use the
    web admin tool to configure settings for your application. Use
    the Website->Asp.Net Configuration option in Visual Studio.
    A full list of settings and comments can be found in
    machine.config.comments usually located in
    \Windows\Microsoft.Net\Framework\v2.x\Config
-->
<configuration xmlns="http://schemas.microsoft.com/.NetConfiguration/v2.0">
    <appSettings>
    <add key="com.webservicex.www.sendsmsworld" value="http://www.webservicex.com/sendsmsworld.asmx"/>
    </appSettings>
    <connectionStrings>
        <add name="clientConnectionString" connectionString="Provider=Microsoft.Jet.OLEDB.4.0;Data Source=&quot;C:\Documents and Settings\Gis04\Desktop\cms\client.mdb&quot;;Jet OLEDB:Database Password=admin" providerName="System.Data.OleDb"/>
    </connectionStrings>
    <system.web>
        <!--
            Set compilation debug="true" to insert debugging
            symbols into the compiled page. Because this
            affects performance, set this value to true only
            during development.
            Visual Basic options:
            Set strict="true" to disallow all data type conversions
            where data loss can occur.
            Set explicit="true" to force declaration of all variables.
        -->
        <compilation debug="true" strict="false" explicit="true">
            <assemblies>
                <add assembly="System.Web.Extensions, Version=1.0.61025.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35"/></assemblies></compilation>
        <pages>
            <namespaces>
                <clear/>
                <add namespace="System"/>
                <add namespace="System.Collections"/>
                <add namespace="System.Collections.Specialized"/>
                <add namespace="System.Configuration"/>
                <add namespace="System.Text"/>
                <add namespace="System.Text.RegularExpressions"/>
                <add namespace="System.Web"/>
                <add namespace="System.Web.Caching"/>
                <add namespace="System.Web.SessionState"/>
                <add namespace="System.Web.Security"/>
                <add namespace="System.Web.Profile"/>
                <add namespace="System.Web.UI"/>
                <add namespace="System.Web.UI.WebControls"/>
                <add namespace="System.Web.UI.WebControls.WebParts"/>
                <add namespace="System.Web.UI.HtmlControls"/>
            </namespaces>
        </pages>
        <!--
            The <authentication> section enables configuration
            of the security authentication mode used by
            ASP.NET to identify an incoming user.
        -->
        <authentication mode="Windows"/>
        <!--
            The <customErrors> section enables configuration
            of what to do if/when an unhandled error occurs
            during the execution of a request. Specifically,
            it enables developers to configure html error pages
            to be displayed in place of a error stack trace.
        <customErrors mode="RemoteOnly" defaultRedirect="GenericErrorPage.htm">
            <error statusCode="403" redirect="NoAccess.htm" />
            <error statusCode="404" redirect="FileNotFound.htm" />
        </customErrors>
        -->
    </system.web>
</configuration>
Posted
Updated 17-May-10 2:34am
v3

Check that what you are typing matches what you uploaded. Are you providing a file extension? Does it match? Have you got the files for any security system loaded? What does your web.config file look like?

Answer these via a comment, or by editing your original question.
   
You need to configure your IIS on the server to show your website. Have you done that?

Okay, just do a simple thing. *This is just a test*
After you have copied the website on the server, right click on the root folder and select properties. On the web sharing tab, select share this folder. Give an alias (your website name) and press Ok.
Now open a web browser on any client machine. Type http://ServerIP/WebsiteName/ and press enter. See if you can see your website.
   

This content, along with any associated source code and files, is licensed under The Code Project Open License (CPOL)




CodeProject, 20 Bay Street, 11th Floor Toronto, Ontario, Canada M5J 2N8 +1 (416) 849-8900