Click here to Skip to main content
15,174,684 members
Please Sign up or sign in to vote.
1.00/5 (3 votes)
See more:
I create an setup file and installed it on my computer
it works great.
but on other computer it installs but does not run.
(when i run it on other computer , i see "COM surrogate" open in task manager and i can see my app too. after 2 second "COM surrogate" quit.)
two computers are 64 bit and my app is 64 bit too.
i create simple project and create a setup file for it and installed it on each computer . it runs in each computer without any problem.
my app need two prerequisite.1).net framwork 4.5 and 2)sql server 2012
as i said it install perfectlly just does not run.
Posted
Comments
Maciej Los 26-Oct-14 13:50pm
   
"does not run" is not informative at all!
Sergey Alexandrovich Kryukov 26-Oct-14 22:10pm
   
You provide no information on your problem. Of course, if some application is bad, it may or may not run. The solution is to write better application. Please do the debugging and other research on your application, find the problem and fix it. If you think that my advice is not detailed enough, think at this: is your post detailed enough?
—SA

1 solution

I guess one difference between the computers is that your computer is a development PC with Visual Studio installed. This can be a problem sometimes.

Another difference could be that on your PC you run as admin and on the other PC the privileges are more restricted.

If you don't get any run time errors, make sure you don't have ignored errors in your code, such as empty catch clauses. It is very common by rookies to code like that.

You can also add a log file functionality in your code and save to disk, like
I am here now.
Init method A.
Exit method A.

or similar.
Also save any error messages like
C#
catch (Exception ex)
{
   streamWriter.WriteLine(ex.ToString());
   streamWriter.Flush();
}

Now it will be easier trace the execution and find the problem.

Don't forget to flush the writer object after each written line.
If your program crashes without closing the file and you didn't flush properly, the file will be empty.
   
Comments
4L4K1 27-Oct-14 7:21am
   
Thank you very much to answer me.
I did what you said and you solved it.
It runs now.
George Jonsson 27-Oct-14 8:00am
   
You are welcome.

This content, along with any associated source code and files, is licensed under The Code Project Open License (CPOL)

  Print Answers RSS
Top Experts
Last 24hrsThis month



CodeProject, 20 Bay Street, 11th Floor Toronto, Ontario, Canada M5J 2N8 +1 (416) 849-8900