Click here to Skip to main content
15,120,478 members
Please Sign up or sign in to vote.
1.00/5 (1 vote)
Hello
I have one application which runs fine on other windows version except Windows 8. On windows 8 I am getting error for .net framework 3.5 not installed. As It is in prerequisite list in my windows installer . So when I select check box, It will start installing but then its throwing error So I want to know whether the source of .net framework set up for windows 8 is different then other? Or What should I do to include correct setup in installer which works fine on every version including windows 8.
Posted
Comments
[no name] 5-Nov-14 23:31pm
   
Hi neha,
did u check this link ? http://msdn.microsoft.com/en-us/library/hh506443(v=vs.110).aspx
nehajain8 5-Nov-14 23:38pm
   
Yes and I am able to install it offline by using executing command. But with the help of that I am able to enable feature. If I want to include this as prerequisite in my setup project what should I do ?

Why? This version of windows comes with .NET 4.5. To enable some other versions for compatibility, please read this:
http://windows.microsoft.com/en-us/windows-8/net-framework-windows-8[^],
http://msdn.microsoft.com/en-us/library/hh506443%28v=vs.110%29.aspx[^],
http://support.microsoft.com/kb/2785188[^].

How to do it in your installer, depends on the installation toolkit you use. For example, you can use DISM in a custom installation action:
http://msdn.microsoft.com/en-us/library/windows/desktop/dd371719%28v=vs.85%29.aspx[^],
http://stackoverflow.com/questions/12897326/redistributable-offline-net-framework-3-5-installer-for-windows-8[^].

—SA
   
v3
Comments
BillWoodruff 6-Nov-14 6:01am
   
+5
   
Thank you, Bill.
—SA

This content, along with any associated source code and files, is licensed under The Code Project Open License (CPOL)




CodeProject, 20 Bay Street, 11th Floor Toronto, Ontario, Canada M5J 2N8 +1 (416) 849-8900