Click here to Skip to main content
14,828,250 members
Please Sign up or sign in to vote.
0.00/5 (No votes)
See more:
I have create crystal report but not display in browser. when i view design view in aspx page report is display but in browser report are not display. please give me a solution. thanks

XML
<CR:CrystalReportViewer ID="CrystalReportViewer1" runat="server" AutoDataBind="true" Height="1202px" ReportSourceID="CrystalReportSource1" ToolPanelWidth="200px" Width="1104px" ToolPanelView="None" Visible="true"/>
<CR:CrystalReportSource runat="server" ID="CrystalReportSource1" Visible="true">
Posted
Updated 21-Dec-20 7:55am

I think there is some problem in finding Resource from default Resource-Uri for formatting of crystal report.

For proper formatting Copy
C#
C:\inetpub\wwwroot\aspnet_client\system_web\4_0_30319\crystalreportviewers13

this folder into your project.

And past these lines into your web.config file
C#
<configSections>
<sectionGroup name="businessObjects">
  <sectionGroup name="crystalReports">
    <section name="rptBuildProvider" type="CrystalDecisions.Shared.RptBuildProviderHandler, CrystalDecisions.Shared, Version=13.0.2000.0, Culture=neutral, PublicKeyToken=692fbea5521e1304, Custom=null" />
       <section name="crystalReportViewer" type="System.Configuration.NameValueSectionHandler" />
  </sectionGroup>
</sectionGroup>
  </configSections>
<businessObjects>
  <crystalReports>
    <rptBuildProvider>
      <add embedRptInResource="true" />
    </rptBuildProvider>
    <crystalReportViewer>
          <add key="ResourceUri" value="/crystalreportviewers13" />
  </crystalReportViewer>
  </crystalReports>
</businessObjects>


This will help you
   
v2
Comments
[no name] 13-Nov-14 8:21am
   
Thank you its working
Deepu S Nair 13-Nov-14 8:29am
   
If it helps you please mark it as answer
Madhav Gunjal 20-Nov-15 8:07am
   
I HAVE ALSO A SAME PROBLEM AND I TRIED THIS BUT IT'S NOT WORKING,IT'S SHOWING THE ERROR AS "The requested page cannot be accessed because the related configuration data for the page is invalid."
Madhav Gunjal 21-Nov-15 0:21am
   
this setting is for framework 3.5 can you provide the same setting for .framework 4 and above
After two weeks of looking for a solution the above worked. Coping the specified folder into the Project folder and pasting the above code into the webconfig file.
Why can't Crystal Reports (SAP) and Microsoft make this solution easier at installation?
   
Comments
CHill60 22-Dec-20 10:46am
   
If you want to comment on a solution then use the "Have a Question or Comment?" link next to it. This is not a solution to the original post.
Thank you very much it is working properly
   
Thank u.. its work..

#HappyCoding
   
Comments
Richard Deeming 22-May-18 15:10pm
   
If you want to reply to a solution, click the "Have a Question or Comment?" button under that solution.

DO NOT post your reply as a new "solution".
At the Head form where you load and have the crystal report viewer call this java script file.

<head runat="server">
  <title>View Report</title>
  <script lang="javaScript" type="text/javascript" src="crystalreportviewers13/js/crviewer/crv.js"></script> 
</head>
   
Comments
CHill60 11-Nov-19 12:05pm
   
Did you notice that the OP thanked Deepu S Nair 5 years ago for posting Solution 1 which solved the problem

This content, along with any associated source code and files, is licensed under The Code Project Open License (CPOL)




CodeProject, 20 Bay Street, 11th Floor Toronto, Ontario, Canada M5J 2N8 +1 (416) 849-8900