Click here to Skip to main content
15,512,456 members
Please Sign up or sign in to vote.
0.00/5 (No votes)
See more:
Hi Folks

I asked this question in the server discussion area yesterday but I'm no further forward. Hoping for more success here.

I currently have a .NET 4.0 website successfully running on Windows Server 2008 using a private deployment of SQL Compact 4.0. The database dlls reside in the application's bin folder.

I am moving to a new web host company and I want to test this on Windows 2012, ultimately with a view to moving to .NET 4.5 and, later, SQL Server. I am using a brand new server installation.

My starting point was to move across all of my website folders, including a test database and SQLCE dlls and test the site - a straight copy of the existing folders and contents.

Unfortunately I get the following error message when loading the home page for the first time. "Unable to find the requested .Net Framework Data Provider. It may not be installed. "

The first part of the trace states:

[ArgumentException: Unable to find the requested .Net Framework Data Provider. It may not be installed.]
System.Data.Common.DbProviderFactories.GetFactory(String providerInvariantName) +1480919
System.Data.EntityClient.EntityConnection.GetFactory(String providerString) +26

[ArgumentException: The specified store provider cannot be found in the configuration, or is not valid.]
System.Data.EntityClient.EntityConnection.GetFactory(String providerString) +91
System.Data.EntityClient.EntityConnection.ChangeConnectionString(String newConnectionString) +246
System.Data.EntityClient.EntityConnection..ctor(String connectionString) +43
System.Data.Objects.ObjectContext.CreateEntityConnection(String connectionString) +85

etc


I am still learning .NET and server environment so please be kind. I have researched for answers today also but it seems to raise more questions than answers for me.

This link doesn't seem to indicate I am doing anything wrong with my private deployment of SQL Compact, though clearly something isn't right.

Given my setup and the errors shown is there a best place to look/check first?

Any ideas?

Cheers

Paul ...
Posted
Comments
Paul D D 19-Nov-14 8:01am    
Forgot to add the link I referred to ... http://technet.microsoft.com/en-us/library/gg213826(v=sql.110).aspx

1 solution

Have your hosting provider install SQL CE on the server? If not, please kindly go to http://www.microsoft.com/en-us/download/details.aspx?id=17876[^] and you can install it
 
Share this answer
 

This content, along with any associated source code and files, is licensed under The Code Project Open License (CPOL)



CodeProject, 20 Bay Street, 11th Floor Toronto, Ontario, Canada M5J 2N8 +1 (416) 849-8900