Click here to Skip to main content
13,835,377 members
Rate this:
 
Please Sign up or sign in to vote.
See more:
Hello,

I am using Crystal Reports Basic for Visual Studio 2008, and using C# to
program the application.

I am using a dynamically created DataTable as a Data Source for a Crystal Report. Everything is working as it should, except that it shows only one row per page in my report. I have the Database Fields in the Details section, but I have "NewPageAfter" and "NewPageAfter" set to false.

How do I output a DataTABLE in TABLE format? It seems like it should be so easy.

Thanks.
Posted
Comments
Sandeep Mewara 1-Jun-10 16:33pm
   
Have a look at the article i have referred to. It would be helpful to track down the steps.
Sandeep Mewara 4-Jun-10 12:43pm
   
:thumbs up: :D
Rate this: bad
 
good
Please Sign up or sign in to vote.

Solution 1

Pull in the field in the detail section and display data in it! They act as the table. Design the table as you want (columns and arrangement)

Dropping the fields in Detail section should do the job for you. Have a look at this article:Crystal Reports and Reporting Services[^]
   
v3
Comments
ahiggins1986 1-Jun-10 16:27pm
   
I only have Pointer, Text Object, Line Object, and Box Object in my toolbox. Can't find Table in toolbox Items.

Also, I'm not using the text box, I'm clicking and dragging on the Columns from Field Explorer->DatabaseFields->MyDataTable->Column
ahiggins1986 1-Jun-10 16:41pm
   
This is what I've been doing all along. My problem is that it shows ONE record per page. I have read your article, and my setup looks identical to the one there.
Rate this: bad
 
good
Please Sign up or sign in to vote.

Solution 2

If you right click the detail section in which you had put up the fields, there would be 'Section expert'. In that, there must be an option of 'Keep Together' - tick it. Try this!
   
Comments
ahiggins1986 1-Jun-10 17:05pm
   
This was already checked, lol. Thanks for your help Sandeep. I'm going to continue the quest for the truth tomorrow, as work is done now.
ahiggins1986 4-Jun-10 11:56am
   
It was checked in the property window, but not the right-click formatting options. Odd.

This content, along with any associated source code and files, is licensed under The Code Project Open License (CPOL)

  Print Answers RSS
Top Experts
Last 24hrsThis month


Advertise | Privacy | Cookies | Terms of Service
Web03 | 2.8.190114.1 | Last Updated 1 Jun 2010
Copyright © CodeProject, 1999-2019
All Rights Reserved.
Layout: fixed | fluid

CodeProject, 503-250 Ferrand Drive Toronto Ontario, M3C 3G8 Canada +1 416-849-8900 x 100